summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-20 15:09:00 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-20 15:09:00 +0200
commit6fe98b0673c2e06667ee835c93bf22d34a1c6117 (patch)
tree3dc014372480f33b9aebc048c8b98339f4edb68d /dev-ros/rqt_srv/rqt_srv-0.4.2.ebuild
parentdev-ros/rqt_shell: Bump to 0.4.2. (diff)
downloadgentoo-6fe98b0673c2e06667ee835c93bf22d34a1c6117.tar.gz
gentoo-6fe98b0673c2e06667ee835c93bf22d34a1c6117.tar.bz2
gentoo-6fe98b0673c2e06667ee835c93bf22d34a1c6117.zip
dev-ros/rqt_srv: Bump to 0.4.2.
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-ros/rqt_srv/rqt_srv-0.4.2.ebuild')
-rw-r--r--dev-ros/rqt_srv/rqt_srv-0.4.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/rqt_srv/rqt_srv-0.4.2.ebuild b/dev-ros/rqt_srv/rqt_srv-0.4.2.ebuild
new file mode 100644
index 000000000000..c2acda34aa27
--- /dev/null
+++ b/dev-ros/rqt_srv/rqt_srv-0.4.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for introspecting available ROS message types"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosmsg[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_msg[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"