summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 18:35:18 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 19:04:21 +0200
commita5a5824ce1f87a71b63eb75c6297247bc0f489e7 (patch)
treebd4f96b52c87f2ae05de680283ed85b6d1916912 /dev-ros/tf2_kdl/tf2_kdl-0.5.12.ebuild
parentdev-ros/tf2_ros: Initial import. Ebuild by me. (diff)
downloadgentoo-a5a5824ce1f87a71b63eb75c6297247bc0f489e7.tar.gz
gentoo-a5a5824ce1f87a71b63eb75c6297247bc0f489e7.tar.bz2
gentoo-a5a5824ce1f87a71b63eb75c6297247bc0f489e7.zip
dev-ros/tf2_kdl: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/tf2_kdl/tf2_kdl-0.5.12.ebuild')
-rw-r--r--dev-ros/tf2_kdl/tf2_kdl-0.5.12.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/tf2_kdl/tf2_kdl-0.5.12.ebuild b/dev-ros/tf2_kdl/tf2_kdl-0.5.12.ebuild
new file mode 100644
index 000000000000..8c415ce33eda
--- /dev/null
+++ b/dev-ros/tf2_kdl/tf2_kdl-0.5.12.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry_experimental"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="KDL binding for tf2"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-cpp/eigen:3
+ dev-ros/tf2
+ dev-ros/tf2_ros
+ dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
+ sci-libs/orocos_kdl
+ dev-ros/tf2_msgs[${PYTHON_USEDEP}]
+ dev-ros/cmake_modules
+"
+DEPEND="${RDEPEND} test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"