summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-11-14 07:29:01 +0100
committerHans de Graaff <graaff@gentoo.org>2016-11-14 07:29:01 +0100
commitc38ad61b5abe67df32d547ff3b18d88313357449 (patch)
tree96d733d671351b3747671b966c1e8a5c021dc1d9 /dev-ruby/fakeweb
parentdev-ruby/samuel: cleanup (diff)
downloadgentoo-c38ad61b5abe67df32d547ff3b18d88313357449.tar.gz
gentoo-c38ad61b5abe67df32d547ff3b18d88313357449.tar.bz2
gentoo-c38ad61b5abe67df32d547ff3b18d88313357449.zip
dev-ruby/fakeweb: cleanup
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/fakeweb')
-rw-r--r--dev-ruby/fakeweb/fakeweb-1.3.0-r1.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-ruby/fakeweb/fakeweb-1.3.0-r1.ebuild b/dev-ruby/fakeweb/fakeweb-1.3.0-r1.ebuild
deleted file mode 100644
index 77cea55c6119..000000000000
--- a/dev-ruby/fakeweb/fakeweb-1.3.0-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-USE_RUBY="ruby20"
-
-RUBY_FAKEGEM_DOCDIR="html"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Helper for faking web requests in Ruby"
-HOMEPAGE="https://github.com/chrisk/fakeweb"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE=""
-
-ruby_add_bdepend "
- test? (
- dev-ruby/mocha:0.13
- dev-ruby/test-unit
- dev-ruby/samuel
- dev-ruby/right_http_connection
- )"
-
-all_ruby_prepare() {
- # The package bundles samuel and right_http_connection, remove
- # them and use the packages instead.
- rm -r test/vendor || die "failed to remove bundled gems"
-
- # We don't package sdoc and we don't have the direct template.
- sed -i -e 's/sdoc/rdoc/' -e '/template/d' Rakefile || die
-
- # Require an old enough version of mocha
- sed -i -e '1igem "mocha", "~> 0.13.0"' test/test_helper.rb || die
-
- # Use the test-unit gem to make jruby compatible with newer mocha.
- sed -i -e '1igem "test-unit"' test/test_helper.rb || die
-}
-
-each_ruby_prepare() {
- case ${RUBY} in
- *ruby2[01])
- # Tests fail on mocking of TCPSocket, but fakeweb itself
- # actually works as evidenced by the thor test suite.
- rm test/test_fake_web_open_uri.rb test/test_allow_net_connect.rb test/test_fake_web.rb || die
- ;;
- esac
-}