summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-01-13 08:56:41 +0100
committerHans de Graaff <graaff@gentoo.org>2023-01-13 08:57:55 +0100
commit141611c4931f88124c82096e45a984f7b790590a (patch)
treef60902fc97e67b01ae51fa8b4923d37c5c47f791 /dev-ruby/haml
parentdev-ruby/git: add 1.13.1 (diff)
downloadgentoo-141611c4931f88124c82096e45a984f7b790590a.tar.gz
gentoo-141611c4931f88124c82096e45a984f7b790590a.tar.bz2
gentoo-141611c4931f88124c82096e45a984f7b790590a.zip
dev-ruby/haml: add 6.1.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/haml')
-rw-r--r--dev-ruby/haml/Manifest1
-rw-r--r--dev-ruby/haml/haml-6.1.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-ruby/haml/Manifest b/dev-ruby/haml/Manifest
index 10b2e0f0d4a1..8ec052b04d95 100644
--- a/dev-ruby/haml/Manifest
+++ b/dev-ruby/haml/Manifest
@@ -1 +1,2 @@
DIST haml-5.2.2.tar.gz 129833 BLAKE2B d68c24c7a3c817d6d364b2ec92b84b4f56f4fffa48b99d17b2df27da35f50b1fb1f69b184a7b21d899c476e0d4c8ad2b940a7cb2995ec24ecdafab8ef61fe393 SHA512 1aec59fab20d8139a5dfedde2007fa8137a377a345e4d30229f9d1140d56cdf970c8ae70e2647e6a408d7fa543a16050f66a8a636efa6a6b1f91ee1ffcc136c1
+DIST haml-6.1.1.tar.gz 669644 BLAKE2B 239b3a1fe02bcd1e2981198ba7c54c71ca2af0947102fcea6cd600cc6579294856baa290589a7d3a015e54df8bcecf8e50175cf2189e8f4f9c6f9721a558bcc9 SHA512 7d732be085b41b8f0eec418600a82b51c68301081165aa636fa342ae26b74215a202a4b15e592da980d9a7fbe24bad01399f599770420133c4b6ab7523386fa5
diff --git a/dev-ruby/haml/haml-6.1.1.ebuild b/dev-ruby/haml/haml-6.1.1.ebuild
new file mode 100644
index 000000000000..1bd1fbf34089
--- /dev/null
+++ b/dev-ruby/haml/haml-6.1.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTENSIONS=(ext/haml/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR="lib/haml"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md REFERENCE.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby web page templating engine"
+HOMEPAGE="https://haml.info/"
+SRC_URI="https://github.com/haml/haml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="doc test"
+
+ruby_add_rdepend ">=dev-ruby/temple-0.8.2 dev-ruby/thor dev-ruby/tilt:*"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/minitest:5
+ dev-ruby/nokogiri
+ >=dev-ruby/railties-6.0
+ >=dev-ruby/activemodel-6.0
+ >=dev-ruby/actionpack-6.0
+ )
+ doc? (
+ dev-ruby/yard
+ )"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -i -e '/bundler/ s:^:#: ; /Bundler/,/end/ s:^:#:' Rakefile || die
+ sed -i -e '/bundler/I s:^:#:' \
+ -e '/simplecov/I s:^:#:' \
+ test/test_helper.rb || die
+ # Remove tests that fails when RedCloth is available
+ rm -f test/haml/filters/markdown_test.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -rtest_helper -e 'Dir["test/haml/**/*_test.rb"].each { require _1 }' || die
+}