summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-09-30 07:35:06 +0200
committerHans de Graaff <graaff@gentoo.org>2024-09-30 07:35:06 +0200
commit509e1517ab90cb1ed52bcb09368d46d24d4be43f (patch)
tree229b3831bade36c38fa4a905aaceb7465ce8d14e /dev-ruby/rexml
parentdev-ruby/net-http-persistent: add 4.0.4 (diff)
downloadgentoo-509e1517ab90cb1ed52bcb09368d46d24d4be43f.tar.gz
gentoo-509e1517ab90cb1ed52bcb09368d46d24d4be43f.tar.bz2
gentoo-509e1517ab90cb1ed52bcb09368d46d24d4be43f.zip
dev-ruby/rexml: add 3.3.8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rexml')
-rw-r--r--dev-ruby/rexml/Manifest1
-rw-r--r--dev-ruby/rexml/rexml-3.3.8.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/rexml/Manifest b/dev-ruby/rexml/Manifest
index 77249db2ff4e..8d50fb98d9e7 100644
--- a/dev-ruby/rexml/Manifest
+++ b/dev-ruby/rexml/Manifest
@@ -3,3 +3,4 @@ DIST rexml-3.3.4.tar.gz 467302 BLAKE2B d8b86d51233ae277eaa25a796a4c895f4cf4d8e49
DIST rexml-3.3.5.tar.gz 467588 BLAKE2B e32270fa6411f776e2e325f942a235eea6ee6cd72e33bf28cea69eeb6dbd40cc334f84d30c962093dd5644fb6c2cb77589229b415ae23e31d3899ae26f325f12 SHA512 401441a7c54533a0e01607af62c142cd9d767aa46dbadc5d18dc57e7542ff4518eba4c77206ff6c4ed6113eba87f30730b96469f64701efb5cb08cb578cd5a48
DIST rexml-3.3.6.tar.gz 468635 BLAKE2B ce8e4dfb455fb284fdbd2dd11e452190f4eff94665041aadf0211da339d54ff4978101164a85a108cfa5f4c857f0e4c92629bb5464f38b4110d36bb5b4284173 SHA512 02b4555bd8d1474a123f617d2bd5d23a6769ab97ceb672abfec5244e189a4222ab662e509d064e66d91b5f60443d23b1bdf11c334598f203082617d2cd031fae
DIST rexml-3.3.7.tar.gz 468887 BLAKE2B ed13b7ad00dd756e4d3736247101a512503d9c756e772990457db13e1fdc46a21973228f63ee30ab31e8fd684910549fdf3a08670d9cc2b9bf78623f36ba23f0 SHA512 4f54996306869076ef7f2c0a2bd1dfe6f20a28580158236f335a8e9f41a035d864420777042d12379cfa18b460c1b14865924e0718e8042568d1a864da1d6ecb
+DIST rexml-3.3.8.tar.gz 469446 BLAKE2B d5f49f17f98438c117eb3f1b91b699cb8a93944b4077b1fcfafdf73155556c1aa367178bd336e809b45af78418842b1c127f22e2071f66eb8aeb71bab88ace0d SHA512 13c09c66454d0938855a8a3243f05ffc467b239521320c0adc0aa6bc55dbc48042dfea9bfee25b04b49f54cf13ae7e2532627adbfb3dd7b6aa24d1088e9d80d6
diff --git a/dev-ruby/rexml/rexml-3.3.8.ebuild b/dev-ruby/rexml/rexml-3.3.8.ebuild
new file mode 100644
index 000000000000..802c814bb1f9
--- /dev/null
+++ b/dev-ruby/rexml/rexml-3.3.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An XML toolkit for Ruby"
+HOMEPAGE="https://github.com/ruby/rexml"
+SRC_URI="https://github.com/ruby/rexml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+ruby_add_rdepend "dev-ruby/strscan"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit dev-ruby/test-unit-ruby-core )"
+
+all_ruby_prepare() {
+ sed -i -e 's:require_relative ":require "./:' -e 's/__dir__/"."/' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Ensure we use the (new enough) gem version of strscan. The
+ # versions bundled with ruby up to at least 3.3.1 are all too old.
+ sed -e '3igem "strscan"' \
+ -i test/helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/run.rb || die
+}