summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-10-23 07:12:20 +0200
committerHans de Graaff <graaff@gentoo.org>2020-10-23 07:12:20 +0200
commitac567400e303fd7a1b1aa9f72ef3980490901193 (patch)
tree76a890b8e7d81d21dfa782755e00e70569e770c8 /dev-ruby/tty-command
parentdev-ruby/rouge: add 3.24.0 (diff)
downloadgentoo-ac567400e303fd7a1b1aa9f72ef3980490901193.tar.gz
gentoo-ac567400e303fd7a1b1aa9f72ef3980490901193.tar.bz2
gentoo-ac567400e303fd7a1b1aa9f72ef3980490901193.zip
dev-ruby/tty-command: add 0.10.0
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/tty-command')
-rw-r--r--dev-ruby/tty-command/Manifest1
-rw-r--r--dev-ruby/tty-command/tty-command-0.10.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/tty-command/Manifest b/dev-ruby/tty-command/Manifest
index 60b47ec063aa..2549bd1792fb 100644
--- a/dev-ruby/tty-command/Manifest
+++ b/dev-ruby/tty-command/Manifest
@@ -1 +1,2 @@
+DIST tty-command-0.10.0.tar.gz 31592 BLAKE2B 34bb5a926ad32b236585a3e0d5bcfebc6a7d8b3ab3c63e60db30441f6f66b757260b35b40fe5e22ec96162253716d27111c0def59133e80c9dabbaf5f87f68da SHA512 5397f154603b1516be717ac35665623292d1454c18824cc688227f998c8d14e0744fc143e29dd93e737ae78f1800a1e5812ed6cbacb0df6ac4db28b2f096fcde
DIST tty-command-0.9.0.tar.gz 30463 BLAKE2B fc0436a80b4b73040a89f085315f50e464efd91d6ee222f7b94eec5b94700089ae22963580febf8296377c859c67f1f21772ecd24d325af76308183df6070e2a SHA512 12c5c238ea34b7236b1c1b3115a7f490ae3986de686359ed390428f766aabdb35de7a1b29363b5be4e09e0fb6888b0c8a30eb466153f64b1d8a77620a657ffac
diff --git a/dev-ruby/tty-command/tty-command-0.10.0.ebuild b/dev-ruby/tty-command/tty-command-0.10.0.ebuild
new file mode 100644
index 000000000000..861340515246
--- /dev/null
+++ b/dev-ruby/tty-command/tty-command-0.10.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Terminal color capabilities detection"
+HOMEPAGE="https://github.com/piotrmurach/tty-command"
+SRC_URI="https://github.com/piotrmurach/tty-command/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/pastel-0.8:0"
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}