summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2025-01-22 07:56:49 +0100
committerHans de Graaff <graaff@gentoo.org>2025-01-22 07:58:40 +0100
commit03f68c336785df765cb9bafc58fd21a7d8fbf7c0 (patch)
tree22bfe49af599eb8bdc656b8ddb26bc6cb322be01 /dev-ruby
parentdev-ruby/irb: drop 1.14.0, 1.14.1, 1.14.2 (diff)
downloadgentoo-03f68c336785df765cb9bafc58fd21a7d8fbf7c0.tar.gz
gentoo-03f68c336785df765cb9bafc58fd21a7d8fbf7c0.tar.bz2
gentoo-03f68c336785df765cb9bafc58fd21a7d8fbf7c0.zip
dev-ruby/repl_type_completor: add 0.1.10
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/repl_type_completor/Manifest1
-rw-r--r--dev-ruby/repl_type_completor/repl_type_completor-0.1.10.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/repl_type_completor/Manifest b/dev-ruby/repl_type_completor/Manifest
index a86351580e16..7ec7e4fe64cd 100644
--- a/dev-ruby/repl_type_completor/Manifest
+++ b/dev-ruby/repl_type_completor/Manifest
@@ -1 +1,2 @@
+DIST repl_type_completor-0.1.10.tar.gz 32645 BLAKE2B dae2a9fef40482a1db7ed77f19612a7db95b9471f1b83a89a7ba7d4aa90130c9c9c3e983d9f7714ad9e3f21ec7e09028a862e4ce0d7690606788044e10b794e7 SHA512 8d90b4f8d17a4b38543ea0d8d19bb19414006f308ee262f2002d6cfa15f9297bdd130f4507061474220b3af59494dfd0173ea650105a8df2cdf1507f5f0c1178
DIST repl_type_completor-0.1.9.tar.gz 32275 BLAKE2B aecec4bed189fd1907f7ac50d787b87cc2e9ee22f0042d2888cfbc565e55a231725ed26c2fb5a5776ea7a427ba07def468d3bc6d7ab45576dd7486b3a889bb51 SHA512 c3c88a4127fc37614c8e651b81cbc0636684f2feddd1032f2e4a060b7a6b341d758f64afcb14e8cbfe59306caeba528fb97343cba424d4612f23e095d5486a9e
diff --git a/dev-ruby/repl_type_completor/repl_type_completor-0.1.10.ebuild b/dev-ruby/repl_type_completor/repl_type_completor-0.1.10.ebuild
new file mode 100644
index 000000000000..ea5efa083e4f
--- /dev/null
+++ b/dev-ruby/repl_type_completor/repl_type_completor-0.1.10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33 ruby34"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="repl_type_completor.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Type based completion for REPL"
+HOMEPAGE="https://github.com/ruby/repl_type_completor"
+SRC_URI="https://github.com/ruby/repl_type_completor/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+IUSE="test"
+
+ruby_add_rdepend "
+ dev-ruby/prism:1
+ <dev-ruby/rbs-4
+"
+
+ruby_add_bdepend "test? ( >=dev-ruby/irb-1.10.0 =dev-ruby/rake-13* dev-ruby/test-unit dev-ruby/test-unit-ruby-core )"
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's:_relative ": "./:' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}