summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-04-09 07:21:29 +0200
committerHans de Graaff <graaff@gentoo.org>2024-04-09 07:25:49 +0200
commitd6a21e6d4d0a3dff055a564b35812862f7b754aa (patch)
treeff26a63d2765bc618622b6f3b660c2b7f8aeabc6 /dev-ruby
parentapp-admin/awscli: Bump to 1.32.80 (diff)
downloadgentoo-d6a21e6d4d0a3dff055a564b35812862f7b754aa.tar.gz
gentoo-d6a21e6d4d0a3dff055a564b35812862f7b754aa.tar.bz2
gentoo-d6a21e6d4d0a3dff055a564b35812862f7b754aa.zip
dev-ruby/ruby-mp3info: add ruby33
Fix hoe and minitest deprecations. Update HOMEPAGE. Closes: https://bugs.gentoo.org/928918 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-mp3info/ruby-mp3info-0.8.10-r1.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/dev-ruby/ruby-mp3info/ruby-mp3info-0.8.10-r1.ebuild b/dev-ruby/ruby-mp3info/ruby-mp3info-0.8.10-r1.ebuild
index 41d25de060fb..69e7ed1491da 100644
--- a/dev-ruby/ruby-mp3info/ruby-mp3info-0.8.10-r1.ebuild
+++ b/dev-ruby/ruby-mp3info/ruby-mp3info-0.8.10-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby30 ruby31 ruby32"
+USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_EXTRADOC="History.txt README.md"
RUBY_FAKEGEM_GEMSPEC="ruby-mp3info.gemspec"
@@ -10,19 +10,24 @@ RUBY_FAKEGEM_GEMSPEC="ruby-mp3info.gemspec"
inherit ruby-fakegem
DESCRIPTION="A pure Ruby library for access to mp3 files (internal infos and tags)"
-HOMEPAGE="http://rubyforge.org/projects/ruby-mp3info/"
+HOMEPAGE="https://github.com/moumar/ruby-mp3info"
SRC_URI="https://github.com/moumar/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="test"
DEPEND+=" test? ( media-sound/id3v2 )"
-ruby_add_bdepend "test? ( dev-ruby/hoe dev-ruby/test-unit:2 )"
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
all_ruby_prepare() {
sed -i -e "s:/tmp/test.mp3:${T}/test.mp3:" test/test_ruby-mp3info.rb || die
+ sed -i -e 's/MiniTest/Minitest/' test/helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_ruby-mp3info.rb || die
}