summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-05 19:06:40 +0000
committerSam James <sam@gentoo.org>2020-10-05 19:06:52 +0000
commit586d206311051cc2a1f870768ff391332ea194a8 (patch)
tree8ca4e08bc84c6ddc0549958a22e8a1f594f6c8d3 /dev-scheme/guile/guile-2.0.13-r2.ebuild
parentnet-misc/openssh-8.4_p1-r1: Revbump, enable the X509 USE flag (diff)
downloadgentoo-586d206311051cc2a1f870768ff391332ea194a8.tar.gz
gentoo-586d206311051cc2a1f870768ff391332ea194a8.tar.bz2
gentoo-586d206311051cc2a1f870768ff391332ea194a8.zip
dev-scheme/guile: cleanup old
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-scheme/guile/guile-2.0.13-r2.ebuild')
-rw-r--r--dev-scheme/guile/guile-2.0.13-r2.ebuild80
1 files changed, 0 insertions, 80 deletions
diff --git a/dev-scheme/guile/guile-2.0.13-r2.ebuild b/dev-scheme/guile/guile-2.0.13-r2.ebuild
deleted file mode 100644
index 3e2b18b7c6bb..000000000000
--- a/dev-scheme/guile/guile-2.0.13-r2.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit flag-o-matic autotools
-
-DESCRIPTION="GNU Ubiquitous Intelligent Language for Extensions"
-HOMEPAGE="https://www.gnu.org/software/guile/"
-SRC_URI="mirror://gnu/guile/${P}.tar.gz"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-LICENSE="LGPL-3+"
-IUSE="debug debug-malloc +deprecated +networking +nls +regex +threads" # upstream recommended +networking +nls
-# emacs useflag removal not working
-
-# workaround for bug 596322
-REQUIRED_USE="regex"
-
-RDEPEND="
- >=dev-libs/boehm-gc-7.0:=[threads?]
- dev-libs/gmp:=
- dev-libs/libffi:=
- dev-libs/libltdl:=
- dev-libs/libunistring:0=
- sys-devel/libtool
- sys-libs/ncurses:0=
- sys-libs/readline:0="
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- sys-apps/texinfo
- sys-devel/gettext"
-
-SLOT="12/22" # subslot is soname version
-MAJOR="2.0"
-
-DOCS=( GUILE-VERSION HACKING README )
-
-PATCHES=( "${FILESDIR}/${PN}-2-snarf.patch" )
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- # see bug #178499
- filter-flags -ftree-vectorize
-
- econf \
- --disable-error-on-warning \
- --disable-rpath \
- --enable-posix \
- --without-libgmp-prefix \
- --without-libiconv-prefix \
- --without-libintl-prefix \
- --without-libltdl-prefix \
- --without-libreadline-prefix \
- --without-libunistring-prefix \
- $(use_enable debug guile-debug) \
- $(use_enable debug-malloc) \
- $(use_enable deprecated) \
- $(use_enable networking) \
- $(use_enable nls) \
- $(use_enable regex) \
- $(use_with threads)
-}
-
-src_install() {
- default
-
- # From Novell
- # https://bugzilla.novell.com/show_bug.cgi?id=874028#c0
- dodir /usr/share/gdb/auto-load/$(get_libdir)
- mv "${ED}"/usr/$(get_libdir)/libguile-*-gdb.scm "${ED}"/usr/share/gdb/auto-load/$(get_libdir) || die
-
- # necessary for registering slib, see bug 206896
- keepdir /usr/share/guile/site
-
- # Dark magic necessary for some deps
- dosym libguile-2.0.so /usr/$(get_libdir)/libguile.so
-}