summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/hyphen_show
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/hyphen_show')
-rw-r--r--dev-tex/hyphen_show/Manifest1
-rw-r--r--dev-tex/hyphen_show/files/hyphen_show-gcc34.patch78
-rw-r--r--dev-tex/hyphen_show/hyphen_show-20000425.ebuild32
-rw-r--r--dev-tex/hyphen_show/metadata.xml13
4 files changed, 124 insertions, 0 deletions
diff --git a/dev-tex/hyphen_show/Manifest b/dev-tex/hyphen_show/Manifest
new file mode 100644
index 000000000000..a9cf97a29d80
--- /dev/null
+++ b/dev-tex/hyphen_show/Manifest
@@ -0,0 +1 @@
+DIST hyphen-show_20000425.orig.tar.gz 8723 SHA256 4b2bee9e7f6a6b9e59bc1649b1c2bae42c58920ff0ca7f9728ec3c64f609aa2c SHA512 77904ac52171dd245f900e80c7b7ef48a67fc8dffe13dcb3f321a8582c4fe907295f1f19e8513cc612d2089aedc67c29ba03e1928af94c7009e6fd7327c6552e WHIRLPOOL 059b1d0a6662dc3aa9d5e0e5f2f8ea7ee0111cb5e5464b7adfbba35c6ee8ca82a89ea6e617f461a888096f462bdd1a78e45f0be0bb8d66b53ec1175efda77f53
diff --git a/dev-tex/hyphen_show/files/hyphen_show-gcc34.patch b/dev-tex/hyphen_show/files/hyphen_show-gcc34.patch
new file mode 100644
index 000000000000..9da98c9d1000
--- /dev/null
+++ b/dev-tex/hyphen_show/files/hyphen_show-gcc34.patch
@@ -0,0 +1,78 @@
+--- hyphen-show-20000425/hyphen_show.c.orig 2002-01-29 00:08:12.000000000 +0100
++++ hyphen-show-20000425/hyphen_show.c 2005-09-29 09:34:01.000000000 +0200
+@@ -79,9 +79,9 @@
+ Linux (gcc),
+ SGI IRIS 5.2 */
+ #include <sys/fcntl.h>
+- int close(int);
+- int read(int,char *,unsigned);
+- int isalpha(char);
++ #include <unistd.h>
++ #include <stdlib.h>
++ #include <ctype.h>
+ #endif
+
+ int gchar(unsigned char *);
+@@ -106,7 +106,6 @@
+ char zugelassen(char, unsigned char);
+ char* text_clear(char *, int *);
+ void eop(void);
+-long pow(int,int);
+ void eingabe(long *, unsigned char);
+ void right(unsigned char);
+ void w0(void);
+@@ -114,7 +113,7 @@
+ void x0(void);
+ void x(unsigned char);
+ void down(unsigned char);
+-void y0(void);
++void y_0(void);
+ void y(unsigned char);
+ void z0(void);
+ void z(unsigned char);
+@@ -491,24 +490,16 @@
+ s_p = 0;
+ }
+
+-long pow(int b,int p)
+- { int w,k;
+- w = b;
+- for (k=1; k < p; k++) {w = w *b;};
+- return w;
+- }
+-
+ void eingabe(long* dd, unsigned char k)
+- { char neg; unsigned char hk;
++ { unsigned char hk;
+ long hn,hw;
+ hw = (int) e_inbyte();
+- neg = FALSE;
+- if (hw > 127) {neg = TRUE;};
++ if (hw > 127) hw -= 256;
+ for (hn = 2; hn <= (long) k; hn++)
+ { hk = e_inbyte();
+ hw = hw*256+hk;
+ };
+- if (neg == TRUE) {*dd = -(pow(2,k*8))+hw; } else *dd = hw;
++ *dd = hw;
+ }
+
+ void right(unsigned char code)
+@@ -544,7 +535,7 @@
+ if (d_v > v_grenze_zeile) a_outimage();
+ }
+
+-void y0(void)
++void y_0(void)
+ { if (d_y > y_grenze) a_outimage();
+ if (abs(d_y) > y_grenze_zeile) a_outimage();
+ }
+@@ -698,7 +689,7 @@
+ else if (k == 152) {x0();} /* x0 */
+ else if (k <= 156) {x(k);} /* x1 bis x4 */
+ else if (k <= 160) {down(k);} /* down1 bis down4 */
+- else if (k == 161) {y0();} /* y0 */
++ else if (k == 161) {y_0();} /* y0 */
+ else if (k <= 165) {y(k);} /* y1 bis y4 */
+ else if (k == 166) {z0();} /* z0 */
+ else if (k <= 170) {z(k);} /* z1 bis z4 */
diff --git a/dev-tex/hyphen_show/hyphen_show-20000425.ebuild b/dev-tex/hyphen_show/hyphen_show-20000425.ebuild
new file mode 100644
index 000000000000..86ee49bea290
--- /dev/null
+++ b/dev-tex/hyphen_show/hyphen_show-20000425.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+MY_PN=${PN//_/-}
+DESCRIPTION="Show hyphenations in DVI files"
+HOMEPAGE="http://packages.debian.org/stable/tex/hyphen-show"
+SRC_URI="mirror://debian/pool/main/h/${MY_PN}/${MY_PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${PN}-gcc34.patch
+}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} hyphen_show.c -o hyphen_show || die
+}
+
+src_install() {
+ dobin hyphen_show || die
+ doman hyphen_show.1 || die
+ dodoc README.hyphen_show || die
+}
diff --git a/dev-tex/hyphen_show/metadata.xml b/dev-tex/hyphen_show/metadata.xml
new file mode 100644
index 000000000000..daedb32cbf48
--- /dev/null
+++ b/dev-tex/hyphen_show/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+<maintainer>
+ <email>ulm@gentoo.org</email>
+</maintainer>
+<longdescription>
+ hyphen_show scans a DVI file, tries to find all hyphenations and writes them
+ to stdout. It is useful to check whether TeX's hyphenation algorithm really
+ did the good job it is supposed to do.
+</longdescription>
+</pkgmetadata>