summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-15 07:30:20 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-15 08:20:20 +0100
commitba984a5de6d91283b89f3c75263d49e0f852ce49 (patch)
treefd6bb77536693463787d0d9555a3a10d109534d4 /dev-util/catfish
parentsys-cluster/ceph: Set USE-default on snappy[static-libs] (diff)
downloadgentoo-ba984a5de6d91283b89f3c75263d49e0f852ce49.tar.gz
gentoo-ba984a5de6d91283b89f3c75263d49e0f852ce49.tar.bz2
gentoo-ba984a5de6d91283b89f3c75263d49e0f852ce49.zip
dev-util/catfish: Bump to 1.4.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/catfish')
-rw-r--r--dev-util/catfish/Manifest1
-rw-r--r--dev-util/catfish/catfish-1.4.13.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-util/catfish/Manifest b/dev-util/catfish/Manifest
index f40cb1e0c5d1..a068888834f6 100644
--- a/dev-util/catfish/Manifest
+++ b/dev-util/catfish/Manifest
@@ -1,2 +1,3 @@
DIST catfish-1.4.10.tar.bz2 213951 BLAKE2B ff8f710d5f3b5d59e98bd6af9b1dd11499ea331b2d7c78945ebc1051d1b49d28069e47bd8aa3f12d57b646fc6764ccd4f365cda9fdfea15f5a3a4334b6e9b17e SHA512 baf9007b2ce2418fa5704e10884f509e4361505537e2ce70a7f8c8c61009094a09d7d032e0a6b4ca174f33bf76783ee2665f781cce47d2b236f2633e25192f29
DIST catfish-1.4.12.tar.bz2 221813 BLAKE2B 4110ca5844a23b482d9cdc72a62ec49f7b6e2e31b861a38f454c4345642b970b9b6cc497bcbc13ce450476d812c1b6e32a762875d2af0f281a31464a43a543e4 SHA512 053b6ad1d818adc515df16952de656b5ffc44b3bcd59221828850fbcb0080958bd1154ec7dfe4952b358e33068a2b7dee4475dd9f6c6b55e6198ece0587745bd
+DIST catfish-1.4.13.tar.bz2 221999 BLAKE2B b487947954832c691a5a1b3bd2a49e7ae1aedecbe2084b86b9ae1c8bd7c95f6d3746f80723d351bed3abac0e2396fcce134072345a908f5ba9f0dfebdd95108f SHA512 a90c695e7c1a2172ea7a5f7f1a292e95aa290693a24f3988a68f2fb4597183ff7526c98925fb3ef8517fbca508a1c3853e0de87ec023be9424d994d63e29c886
diff --git a/dev-util/catfish/catfish-1.4.13.ebuild b/dev-util/catfish/catfish-1.4.13.ebuild
new file mode 100644
index 000000000000..d28399901b9f
--- /dev/null
+++ b/dev-util/catfish/catfish-1.4.13.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A frontend for find, (s)locate, doodle, tracker, beagle, strigi and pinot"
+HOMEPAGE="https://docs.xfce.org/apps/catfish/start"
+SRC_URI="https://archive.xfce.org/src/apps/catfish/${PV%.*}/${P}.tar.bz2"
+
+# yep, GPL-2 only
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ dev-libs/gobject-introspection
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ virtual/freedesktop-icon-theme
+"
+BDEPEND="
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ sys-devel/gettext
+"
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+ rm -r "${ED}"/usr/share/doc/catfish || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}