summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2022-09-16 15:07:29 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-09-16 15:13:52 +0300
commitd92efd99557b34195ea03afa30c872cedc080129 (patch)
tree38e761d825a470883d513ced03e3db846de2bac0 /dev-util/edi
parentmedia-gfx/ephoto: drop 1.5 (diff)
downloadgentoo-d92efd99557b34195ea03afa30c872cedc080129.tar.gz
gentoo-d92efd99557b34195ea03afa30c872cedc080129.tar.bz2
gentoo-d92efd99557b34195ea03afa30c872cedc080129.zip
dev-util/edi: drop 0.8.0-r1
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util/edi')
-rw-r--r--dev-util/edi/edi-0.8.0-r1.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/dev-util/edi/edi-0.8.0-r1.ebuild b/dev-util/edi/edi-0.8.0-r1.ebuild
deleted file mode 100644
index 859c80b1b229..000000000000
--- a/dev-util/edi/edi-0.8.0-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit llvm meson xdg
-
-DESCRIPTION="An EFL-based IDE"
-HOMEPAGE="https://www.enlightenment.org/about-edi
- https://phab.enlightenment.org/w/projects/edi/
- https://github.com/Enlightenment/edi"
-SRC_URI="https://github.com/Enlightenment/edi/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2 GPL-3 LGPL-2.1-with-linking-exception"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="clang"
-
-RDEPEND="|| ( dev-libs/efl[X] dev-libs/efl[wayland] )
- >=dev-libs/efl-1.22.0[eet]
- clang? (
- dev-util/bear
- sys-devel/clang:=
- )"
-DEPEND="${RDEPEND}
- dev-libs/check"
-BDEPEND="virtual/libintl
- virtual/pkgconfig"
-
-llvm_check_deps() {
- has_version "sys-devel/clang:${LLVM_SLOT}"
-}
-
-pkg_setup() {
- use clang && llvm_pkg_setup
-}
-
-src_prepare() {
- default
-
- # fix a QA issue with .desktop file, https://phab.enlightenment.org/T7368
- sed -i '/Version=/d' data/desktop/edi.desktop* || die
-
- # fix 'unexpected path' QA warning
- sed -i 's|share/doc/edi/|share/doc/'${PF}'/|g' doc/meson.build || die
-}
-
-src_configure() {
- local emesonargs=(
- $(meson_use clang bear)
- $(meson_use clang libclang)
- )
-
- if use clang; then
- emesonargs+=(
- -D libclang-headerdir="$(llvm-config --includedir)"
- -D libclang-libdir="$(llvm-config --libdir)"
- )
- fi
-
- meson_src_configure
-}