summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-12 20:23:49 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-13 10:42:32 +0100
commit7b205f67aa1e81d5665d2d88132ee9ce195f852a (patch)
tree1ede02f153b083fafce941f24f5a07ef7322b4c5 /dev-util/peda
parentprofiles/categories: Add dev-{build,debug} (diff)
downloadgentoo-7b205f67aa1e81d5665d2d88132ee9ce195f852a.tar.gz
gentoo-7b205f67aa1e81d5665d2d88132ee9ce195f852a.tar.bz2
gentoo-7b205f67aa1e81d5665d2d88132ee9ce195f852a.zip
Move {sys-devel → dev-debug}/gdb
Closes: https://bugs.gentoo.org/920438 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/peda')
-rw-r--r--dev-util/peda/peda-1.2.ebuild6
-rw-r--r--dev-util/peda/peda-9999.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/dev-util/peda/peda-1.2.ebuild b/dev-util/peda/peda-1.2.ebuild
index df618d1a27f7..9e889d8de922 100644
--- a/dev-util/peda/peda-1.2.ebuild
+++ b/dev-util/peda/peda-1.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit python-single-r1 wrapper
@@ -26,8 +26,8 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
${PYTHON_DEPS}
$(python_gen_cond_dep '
+ dev-debug/gdb[python,${PYTHON_SINGLE_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
- sys-devel/gdb[python,${PYTHON_SINGLE_USEDEP}]
')
"
diff --git a/dev-util/peda/peda-9999.ebuild b/dev-util/peda/peda-9999.ebuild
index e3fd8e0aa2bb..dc8b77cb35cd 100644
--- a/dev-util/peda/peda-9999.ebuild
+++ b/dev-util/peda/peda-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit python-single-r1 wrapper
@@ -26,8 +26,8 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
${PYTHON_DEPS}
$(python_gen_cond_dep '
+ dev-debug/gdb[python,${PYTHON_SINGLE_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
- sys-devel/gdb[python,${PYTHON_SINGLE_USEDEP}]
')
"