summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2023-10-14 14:04:10 +0200
committerSam James <sam@gentoo.org>2023-10-27 04:21:39 +0100
commit5cb52bf20501e4ff686526915794cdff6f171975 (patch)
tree3bc717259b9d3ef7a35e29a71b6383147144c05b /dev-util/pwntools
parentdev-libs/bemenu: fix libxkbcommon dependency (diff)
downloadgentoo-5cb52bf20501e4ff686526915794cdff6f171975.tar.gz
gentoo-5cb52bf20501e4ff686526915794cdff6f171975.tar.bz2
gentoo-5cb52bf20501e4ff686526915794cdff6f171975.zip
dev-util/pwntools: sync live
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/33326 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/pwntools')
-rw-r--r--dev-util/pwntools/pwntools-9999.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-util/pwntools/pwntools-9999.ebuild b/dev-util/pwntools/pwntools-9999.ebuild
index ae6e8ade5145..c560e51d59ec 100644
--- a/dev-util/pwntools/pwntools-9999.ebuild
+++ b/dev-util/pwntools/pwntools-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..11} )
DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
+inherit bash-completion-r1 distutils-r1
DESCRIPTION="CTF framework and exploit development library"
HOMEPAGE="https://github.com/Gallopsled/pwntools"
@@ -57,5 +57,15 @@ python_configure_all() {
src_install() {
distutils-r1_src_install
+ newbashcomp extra/bash_completion.d/pwn pwn
+ newbashcomp extra/bash_completion.d/shellcraft shellcraft
+
+ insinto /usr/share/zsh/site-functions
+ doins extra/zsh_completion/_pwn
+
+ # Disable automatic update check (bug 915496).
+ insinto /etc
+ doins "${FILESDIR}/pwn.conf"
+
rm -r "${ED}/usr/pwntools-doc" || die
}