summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-03-06 16:34:50 -0500
committerMatt Turner <mattst88@gentoo.org>2024-03-06 16:51:18 -0500
commite2085d0c2993116abb98e87a8ec06d59839dbc36 (patch)
tree6d2c9f6a2baada053e8b95cd8d7083b0d60d66a5 /dev-util/vulkan-tools
parentdev-util/vulkan-tools: Synchronize live ebuild (diff)
downloadgentoo-e2085d0c2993116abb98e87a8ec06d59839dbc36.tar.gz
gentoo-e2085d0c2993116abb98e87a8ec06d59839dbc36.tar.bz2
gentoo-e2085d0c2993116abb98e87a8ec06d59839dbc36.zip
dev-util/vulkan-tools: Allow building USE=cube without X/wayland
Closes: https://bugs.gentoo.org/920515 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/vulkan-tools')
-rw-r--r--dev-util/vulkan-tools/vulkan-tools-9999.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/dev-util/vulkan-tools/vulkan-tools-9999.ebuild b/dev-util/vulkan-tools/vulkan-tools-9999.ebuild
index ef16acd05d20..19a70d8f2a16 100644
--- a/dev-util/vulkan-tools/vulkan-tools-9999.ebuild
+++ b/dev-util/vulkan-tools/vulkan-tools-9999.ebuild
@@ -22,9 +22,7 @@ HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Tools"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="cube wayland +X"
-
-REQUIRED_USE="cube? ( || ( X wayland ) )"
+IUSE="cube wayland X"
BDEPEND="${PYTHON_DEPS}
cube? ( ~dev-util/glslang-${PV}:=[${MULTILIB_USEDEP}] )
@@ -72,9 +70,15 @@ multilib_src_configure() {
-DVULKAN_HEADERS_INSTALL_DIR="${ESYSROOT}/usr"
)
- use cube && mycmakeargs+=(
- -DCUBE_WSI_SELECTION=$(usex X XCB WAYLAND)
- )
+ if use cube; then
+ if use X; then
+ mycmakeargs+=(-DCUBE_WSI_SELECTION=XCB)
+ elif use wayland; then
+ mycmakeargs+=(-DCUBE_WSI_SELECTION=WAYLAND)
+ else
+ mycmakeargs+=(-DCUBE_WSI_SELECTION=DISPLAY)
+ fi
+ fi
cmake_src_configure
}