summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSv. Lockal <lockalsash@gmail.com>2024-03-23 17:15:16 +0000
committerSam James <sam@gentoo.org>2024-06-26 10:18:59 +0100
commit09519cfe19d7fbaf470efa2e17970a54e7b36698 (patch)
tree76d17a44d5e7bb8054debdfc8eba1928c2c16334 /dev-util
parentdev-util/hipcc: Revert "Fix invalid path" (diff)
downloadgentoo-09519cfe19d7fbaf470efa2e17970a54e7b36698.tar.gz
gentoo-09519cfe19d7fbaf470efa2e17970a54e7b36698.tar.bz2
gentoo-09519cfe19d7fbaf470efa2e17970a54e7b36698.zip
dev-util/hipcc: use more precise dependencies
* update llvm eclass to r1, allowing to specify LLVM version more precisely * add compiler-rt to RDEPEND, as hipcc automatically links to libclang_rt.builtins-x86_64.a Signed-off-by: Sv. Lockal <lockalsash@gmail.com> dev-util/hipcc: add myself as a maintainer Signed-off-by: Sv. Lockal <lockalsash@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/hipcc/hipcc-6.0.0-r1.ebuild17
-rw-r--r--dev-util/hipcc/metadata.xml6
2 files changed, 15 insertions, 8 deletions
diff --git a/dev-util/hipcc/hipcc-6.0.0-r1.ebuild b/dev-util/hipcc/hipcc-6.0.0-r1.ebuild
index 87fb1e802332..8347b43a7b43 100644
--- a/dev-util/hipcc/hipcc-6.0.0-r1.ebuild
+++ b/dev-util/hipcc/hipcc-6.0.0-r1.ebuild
@@ -3,9 +3,8 @@
EAPI=8
-inherit cmake perl-functions llvm
-
-LLVM_MAX_SLOT=17
+LLVM_COMPAT=( 17 )
+inherit cmake perl-functions llvm-r1
DESCRIPTION="Radeon Open Compute hipcc"
HOMEPAGE="https://github.com/ROCm-Developer-Tools/hipcc"
@@ -20,9 +19,13 @@ RESTRICT="!test? ( test )"
S=${WORKDIR}/HIPCC-rocm-${PV}
-DEPEND="<sys-devel/llvm-18:=
- <sys-devel/clang-18:=
- "
+DEPEND="
+ $(llvm_gen_dep '
+ sys-libs/compiler-rt:${LLVM_SLOT}=
+ sys-devel/llvm:${LLVM_SLOT}=
+ sys-devel/clang:${LLVM_SLOT}=
+ ')
+"
RDEPEND="${DEPEND}
!<dev-util/hip-5.7"
@@ -34,7 +37,7 @@ PATCHES=(
src_prepare() {
cmake_src_prepare
- sed -e "s:\$ROCM_PATH/llvm/bin:$(get_llvm_prefix ${LLVM_MAX_SLOT})/bin:" \
+ sed -e "s:\$ROCM_PATH/llvm/bin:$(get_llvm_prefix)/bin:" \
-i bin/hipvars.pm || die
sed -e "s:\$ENV{'DEVICE_LIB_PATH'}:'${EPREFIX}/usr/lib/amdgcn/bitcode':" \
diff --git a/dev-util/hipcc/metadata.xml b/dev-util/hipcc/metadata.xml
index d280423bad96..b6d25312b735 100644
--- a/dev-util/hipcc/metadata.xml
+++ b/dev-util/hipcc/metadata.xml
@@ -21,7 +21,11 @@
<email>gentoo@holzke.net</email>
<name>Wilfried Holzke</name>
</maintainer>
+ <maintainer type="person">
+ <email>lockalsash@gmail.com</email>
+ <name>Sv. Lockal</name>
+ </maintainer>
<upstream>
- <remote-id type="github">ROCm-Developer-Tools/hipcc</remote-id>
+ <remote-id type="github">ROCm/hipcc</remote-id>
</upstream>
</pkgmetadata>