summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-10-17 09:47:20 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-10-17 09:53:29 +0300
commite13b0def836bef791408baf0b56ce96c408b2787 (patch)
tree45977ecbd3350f6b9f78d6e726045b541a94b7c0 /dev-util
parentdev-python/tree-sitter: cap version of dev-libs/tree-sitter (diff)
downloadgentoo-e13b0def836bef791408baf0b56ce96c408b2787.tar.gz
gentoo-e13b0def836bef791408baf0b56ce96c408b2787.tar.bz2
gentoo-e13b0def836bef791408baf0b56ce96c408b2787.zip
dev-util/pkgcheck: drop 0.10.29-r1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pkgcheck/Manifest1
-rw-r--r--dev-util/pkgcheck/pkgcheck-0.10.29-r1.ebuild94
2 files changed, 0 insertions, 95 deletions
diff --git a/dev-util/pkgcheck/Manifest b/dev-util/pkgcheck/Manifest
index 4fbc4dbb0abc..c9337818246f 100644
--- a/dev-util/pkgcheck/Manifest
+++ b/dev-util/pkgcheck/Manifest
@@ -1,3 +1,2 @@
-DIST pkgcheck-0.10.29.tar.gz 377521 BLAKE2B 91a1a25e6ef173582fc9082b92baa66489fd43c7addfbdd8516b5ea93febbb92b7155de88283ae4a1bb09047a44336ab5c336c5d0808c915eab99e8aa4461576 SHA512 339e332db24ffd716b658a40c66f2a90c6905071827da84ce0d633d882d75cf41bb853725ca30fe2abc8d7535f546925aedc8853fa7f1737854cee251a0ec3ab
DIST pkgcheck-0.10.30.tar.gz 378098 BLAKE2B f80224d707f7656ca45f58932936e1ce780d670be596312532b88940fbe1cfb1c7e14a877a955fc4f21fb003a2ee5c6095c2c6919475cdc95db9be0736050b50 SHA512 078ba2275e39e645eca22a265c9f06c6dd7d1cb310979ab5e48bb86a374b42edc50c0ca8d0bd671a3b51341b7fae80ff2c9adf2dc2eeabd93a545c84373902b4
DIST pkgcheck-0.10.31.tar.gz 379079 BLAKE2B b3e308a8d496c954d649677a41394b1fe1fbab43ce6c629616249306fafaad8e5c2cfa38fc9c838117f7abc381a0c04cea60ba5a2b3ab6a1612bbfc68d858832 SHA512 539cf262c950547dbd85441a7b40e76fcdc0810fdd633ab9042a13c7b19db4826c05ea1bbacf64b50c68884e31fff6a88e6b2baf94b2e6a4b2738123441da6ec
diff --git a/dev-util/pkgcheck/pkgcheck-0.10.29-r1.ebuild b/dev-util/pkgcheck/pkgcheck-0.10.29-r1.ebuild
deleted file mode 100644
index 90d3e0d41012..000000000000
--- a/dev-util/pkgcheck/pkgcheck-0.10.29-r1.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{10..12} )
-inherit elisp-common distutils-r1 optfeature
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/pkgcore/pkgcheck.git
- https://github.com/pkgcore/pkgcheck.git"
- inherit git-r3
-else
- KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
- inherit pypi
-fi
-
-DESCRIPTION="pkgcore-based QA utility for ebuild repos"
-HOMEPAGE="https://github.com/pkgcore/pkgcheck"
-
-LICENSE="BSD MIT"
-SLOT="0"
-IUSE="emacs"
-
-if [[ ${PV} == *9999 ]]; then
- RDEPEND="
- ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]
- ~sys-apps/pkgcore-9999[${PYTHON_USEDEP}]"
-else
- RDEPEND="
- >=dev-python/snakeoil-0.10.7[${PYTHON_USEDEP}]
- >=sys-apps/pkgcore-0.12.25[${PYTHON_USEDEP}]"
-fi
-RDEPEND+="
- >=dev-libs/tree-sitter-bash-0.21.0[python,${PYTHON_USEDEP}]
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/pathspec[${PYTHON_USEDEP}]
- >=dev-python/tree-sitter-0.21.0[${PYTHON_USEDEP}]
- <dev-python/tree-sitter-0.22.0[${PYTHON_USEDEP}]
- emacs? (
- >=app-editors/emacs-24.1:*
- app-emacs/ebuild-mode
- app-emacs/flycheck
- )
-"
-BDEPEND="${RDEPEND}
- >=dev-python/flit-core-3.8[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-vcs/git
- )
-"
-
-SITEFILE="50${PN}-gentoo.el"
-
-distutils_enable_tests pytest
-
-export USE_SYSTEM_TREE_SITTER_BASH=1
-
-src_compile() {
- distutils-r1_src_compile
-
- if use emacs ; then
- pushd "${S}"/contrib/emacs >/dev/null || die
- elisp-compile *.el
- popd >/dev/null || die
- fi
-}
-
-python_install_all() {
- local DOCS=( NEWS.rst )
- [[ ${PV} == *9999 ]] || doman build/sphinx/man/*
- distutils-r1_python_install_all
-
- if use emacs ; then
- elisp-install ${PN} "${S}"/contrib/emacs/*.el{,c}
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-
- optfeature "Network check support" dev-python/requests
- optfeature "Perl module version check support" dev-perl/Gentoo-PerlMod-Version
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}