summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/descent2-demodata
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/descent2-demodata')
-rw-r--r--games-action/descent2-demodata/Manifest1
-rw-r--r--games-action/descent2-demodata/descent2-demodata-1.0.ebuild74
-rw-r--r--games-action/descent2-demodata/metadata.xml5
3 files changed, 80 insertions, 0 deletions
diff --git a/games-action/descent2-demodata/Manifest b/games-action/descent2-demodata/Manifest
new file mode 100644
index 000000000000..8892d01648e6
--- /dev/null
+++ b/games-action/descent2-demodata/Manifest
@@ -0,0 +1 @@
+DIST d2demo10.zip 4306833 SHA256 f8d005670fe5cd17e07ca9bf4022f1045aed436639c37f1e83dd647e14fcec1f SHA512 a4229be701a4b2fc28d3c71591a477d242c1c784dc233c1e9ca6b798b3774de9744d8a91b0b80904b3fe63e1285b79234bf48681cddaeca702b3d9ce4c2b6fab WHIRLPOOL 063961a4cc768f4553c460413d862c7dc604d3be69b87b31af1db6ab7a2da80e1e7213ef590283126b85dd1c45745f4f4f9c61b0bfb286bb178d2cbf57fec77e
diff --git a/games-action/descent2-demodata/descent2-demodata-1.0.ebuild b/games-action/descent2-demodata/descent2-demodata-1.0.ebuild
new file mode 100644
index 000000000000..8494642e8736
--- /dev/null
+++ b/games-action/descent2-demodata/descent2-demodata-1.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+MY_PN="d2demo"
+MY_PV=${PV/./}
+DEMO="${MY_PN}${MY_PV}.zip"
+
+DESCRIPTION="Demo data files for Descent 2"
+HOMEPAGE="http://www.interplay.com/games/product.asp?GameID=109"
+SRC_URI="ftp://ftp.funet.fi/pub/msdos/games/interplay/${DEMO}
+ ftp://ftp.demon.co.uk/pub/ibmpc/dos/games/descent/${DEMO}
+ mirror://3dgamers/descent2/${DEMO}"
+
+# See README.TXT
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+# d2x-0.2.5-r2 may include the demo data itself
+# d2x-0.2.5-r3 does not include the demo data
+#RDEPEND="|| (
+# games-action/d2x-rebirth
+# >=games-action/d2x-0.2.5-r3 )"
+RDEPEND="!<games-action/d2x-0.2.5-r3"
+DEPEND="app-arch/unzip
+ app-arch/unarj"
+
+S=${WORKDIR}
+dir=${GAMES_DATADIR}/d2x
+
+src_unpack() {
+ unpack ${A}
+
+ # This is much more fun than simply downloading
+ # http://www.icculus.org/d2x/data/d2shar10.tar.gz
+ unarj e D2_1.SOW || die
+ mv ${MY_PN}.ham{,1}
+ unarj e D2_2.SOW || die
+ mv ${MY_PN}.ham{,2}
+ mv ${MY_PN}.pig{,2}
+ unarj e D2_3.SOW || die
+ mv ${MY_PN}.pig{,3}
+
+ # From the sows, big porkie pies shall grow
+ cat ${MY_PN}.ham{1,2} > ${MY_PN}.ham || die
+ cat ${MY_PN}.pig{2,3} > ${MY_PN}.pig || die
+
+ rm *{1,2,3} *.{386,bat,ubn} eregcard.ini
+ mkdir controls
+ mv *.b50 descent2.* controls
+}
+
+src_install() {
+ insinto "${dir}"
+ # The "controls" directory is not needed, nor the ini files
+ doins d2demo.*
+
+ dodoc *.txt
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ elog "A client is needed to run the game, e.g. games-action/d2x-xl."
+ elog "Not all Descent 2 clients support the demo data."
+ echo
+}
diff --git a/games-action/descent2-demodata/metadata.xml b/games-action/descent2-demodata/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/descent2-demodata/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>