summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/formido
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/formido')
-rw-r--r--games-action/formido/Manifest2
-rw-r--r--games-action/formido/formido-1.0.1.ebuild47
-rw-r--r--games-action/formido/metadata.xml5
3 files changed, 54 insertions, 0 deletions
diff --git a/games-action/formido/Manifest b/games-action/formido/Manifest
new file mode 100644
index 000000000000..e381e885b2f8
--- /dev/null
+++ b/games-action/formido/Manifest
@@ -0,0 +1,2 @@
+DIST formido-1.0.1.tar.gz 3117496 SHA256 bfea3f9d66fe657551ae8f060de939465634d6eac552849215f33769a9cf4f86 SHA512 72c4b92806eed79290da571c47fcd5427ccd0fafd3d5c5bc1cf641790e13b622eb40f8226e54daf30d1f301743f670115efe8f30279ed83b8fd58d69b6a7e123 WHIRLPOOL 7bf882a4fc41bdbb391efd083f3e866b8a2b37567ef6c0b739b50326777bc2355beffbf4bf857582b06a1b317b78dbf5f30a84a930cef775fabe8cff2d9d076b
+DIST formido-music.tar.bz2 6159005 SHA256 3e9d076139f80e257ba2586c474e18361db5197a555956ebf4dc3053b2a2ce6e SHA512 116ff8af42b68cf641f459b642d42c579decf8ee1314a45de30d4f5452e1669dab5cfdc3a61a72359305f690e686312ea0e1666e724de8b214f3d4d8f6034bd3 WHIRLPOOL 4143aedfb9df1ba0781ebf57cd8c1ae981bbba513ca9aaa2e774723263c6daea2b96534b773d6c67069c762cfb0c606c7028da589122f9ec111cbcd7606fa680
diff --git a/games-action/formido/formido-1.0.1.ebuild b/games-action/formido/formido-1.0.1.ebuild
new file mode 100644
index 000000000000..4413b2482dbf
--- /dev/null
+++ b/games-action/formido/formido-1.0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=4
+inherit eutils toolchain-funcs games
+
+DESCRIPTION="A shooting game in the spirit of Phobia games"
+HOMEPAGE="http://www.mhgames.org/oldies/formido/"
+SRC_URI="http://noe.falzon.free.fr/prog/${P}.tar.gz
+ http://koti.mbnet.fi/lsoft/formido/formido-music.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT=0
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"/data
+ unpack ${PN}-music.tar.bz2
+}
+
+src_prepare() {
+ sed -i \
+ -e "s:g++:$(tc-getCXX):" \
+ -e "/^FLAGS=/s:$: ${CXXFLAGS}:" \
+ -e "/^LINKFLAGS=/s:=.*:=${LDFLAGS}:" \
+ -e "s:\${DATDIR}:${GAMES_DATADIR}/${PN}/data:" \
+ -e "s:\${DEFCONFIGDIR}:${GAMES_DATADIR}/${PN}:" \
+ Makefile \
+ || die "sed failed"
+}
+
+src_install() {
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r ${PN}.cfg data
+ newicon data/icon.dat ${PN}.bmp
+ make_desktop_entry ${PN} Formido /usr/share/pixmaps/${PN}.bmp
+ dodoc README README-1.0.1
+ prepgamesdirs
+}
diff --git a/games-action/formido/metadata.xml b/games-action/formido/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/formido/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>