summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-19 04:22:22 +0100
committerSam James <sam@gentoo.org>2023-04-19 04:22:22 +0100
commitb62f4a1dcac81842a89a24c6ba6347d80ea78b6b (patch)
tree5a147dae24df4b2f889157317c5354107e500fac /games-arcade
parentgames-emulation/ppsspp: fix build w/ gcc 13 (diff)
downloadgentoo-b62f4a1dcac81842a89a24c6ba6347d80ea78b6b.tar.gz
gentoo-b62f4a1dcac81842a89a24c6ba6347d80ea78b6b.tar.bz2
gentoo-b62f4a1dcac81842a89a24c6ba6347d80ea78b6b.zip
games-arcade/commandergenius: fix build w/ gcc 13
Closes: https://bugs.gentoo.org/898756 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/commandergenius/commandergenius-2.4.0-r1.ebuild1
-rw-r--r--games-arcade/commandergenius/files/commandergenius-2.4.0-gcc13.patch23
2 files changed, 24 insertions, 0 deletions
diff --git a/games-arcade/commandergenius/commandergenius-2.4.0-r1.ebuild b/games-arcade/commandergenius/commandergenius-2.4.0-r1.ebuild
index f263f3a77456..82eb3b850b7e 100644
--- a/games-arcade/commandergenius/commandergenius-2.4.0-r1.ebuild
+++ b/games-arcade/commandergenius/commandergenius-2.4.0-r1.ebuild
@@ -38,6 +38,7 @@ BDEPEND="python? ( ${PYTHON_DEPS} )"
PATCHES=(
"${FILESDIR}"/${PN}-2.3.1-build.patch
"${FILESDIR}"/${PN}-2.3.1-paths.patch
+ "${FILESDIR}"/${P}-gcc13.patch
)
pkg_setup() {
diff --git a/games-arcade/commandergenius/files/commandergenius-2.4.0-gcc13.patch b/games-arcade/commandergenius/files/commandergenius-2.4.0-gcc13.patch
new file mode 100644
index 000000000000..866905c251b8
--- /dev/null
+++ b/games-arcade/commandergenius/files/commandergenius-2.4.0-gcc13.patch
@@ -0,0 +1,23 @@
+https://gitlab.com/Dringgstein/Commander-Genius/-/commit/f9fb2808acfca598fe6e6963c84fe9afe5bcd89e
+
+From f9fb2808acfca598fe6e6963c84fe9afe5bcd89e Mon Sep 17 00:00:00 2001
+From: Jan Engelhardt <jengelh@inai.de>
+Date: Tue, 28 Mar 2023 10:56:06 +0200
+Subject: [PATCH] build: resolve compile error with gcc-13
+
+GsKit/base/utils/Unicode.h:16:9: error: 'uint32_t' does not name a type
+GsKit/base/utils/Unicode.h:17:27: error: 'UnicodeChar' was not declared in this scope
+GsKit/base/utils/Unicode.h:17:38: error: template argument 1 is invalid
+...
+--- a/GsKit/base/utils/Unicode.h
++++ b/GsKit/base/utils/Unicode.h
+@@ -11,6 +11,7 @@
+ #ifndef __UNICODE_H__
+ #define __UNICODE_H__
+
++#include <cstdint>
+ #include <string>
+
+ typedef uint32_t UnicodeChar;
+--
+GitLab