summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2025-01-12 21:00:28 +0100
committerMaciej Barć <xgqt@gentoo.org>2025-01-12 22:54:43 +0100
commit0f05faf24ee57553910d5fafe1eddcb6d0438bb0 (patch)
treedd75375414ed70e0109ca95beec2d63d0823ba2b /games-emulation
parentapp-emacs/org-mode: metadata: add upstream tag (diff)
downloadgentoo-0f05faf24ee57553910d5fafe1eddcb6d0438bb0.tar.gz
gentoo-0f05faf24ee57553910d5fafe1eddcb6d0438bb0.tar.bz2
gentoo-0f05faf24ee57553910d5fafe1eddcb6d0438bb0.zip
games-emulation/melonds: bump to 1.0_rc
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/melonds/Manifest1
-rw-r--r--games-emulation/melonds/melonds-1.0_rc.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/games-emulation/melonds/Manifest b/games-emulation/melonds/Manifest
index 5af1950008b6..793f86ba9ac5 100644
--- a/games-emulation/melonds/Manifest
+++ b/games-emulation/melonds/Manifest
@@ -1 +1,2 @@
DIST melonDS-0.9.5_p20241113.tar.gz 3410057 BLAKE2B 6c4e5e8aa1a519a11308d42168c22d6fde8176fe46e96d00edcc34112e16d65aad77d1925b9f1966c198035cccae092902428081f1cf56d40eac30c369477433 SHA512 25b18547899e18e915cfdc0c437472fb39eeac520c478e232783fc5d57430e84b2cd0be1b2bcddfe9f5132877c8278ebb29893e7a104d7731974aa5e44f79914
+DIST melonds-1.0_rc.gh.tar.gz 3594949 BLAKE2B cb4cc8e8d38bc544084c8a22aeba1a6284ef36ed808a84c890a8bcc946bce3fa27622ef965f48bed2808b12e9727b4df21d1e31b1c8ed0ce1ee9a24955d2de5b SHA512 3b7efe02be2aa058a3364c52f20ee528cea70940f9d81c4db5c936da8bf46226a2eadfa7b65c5acbf0dc8253b8108995cf0b55d79f0c70bf6222ac14c9e6e382
diff --git a/games-emulation/melonds/melonds-1.0_rc.ebuild b/games-emulation/melonds/melonds-1.0_rc.ebuild
new file mode 100644
index 000000000000..0c99dd96ef21
--- /dev/null
+++ b/games-emulation/melonds/melonds-1.0_rc.ebuild
@@ -0,0 +1,92 @@
+# Copyright 2019-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+REAL_PN="melonDS"
+REAL_PV="${PV/_rc/rc}"
+REAL_P="${REAL_PN}-${REAL_PV}"
+
+inherit cmake readme.gentoo-r1 toolchain-funcs xdg
+
+DESCRIPTION="Nintendo DS emulator, sorta"
+HOMEPAGE="http://melonds.kuribo64.net
+ https://github.com/Arisotura/melonDS"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/Arisotura/${REAL_PN}"
+else
+ SRC_URI="https://github.com/Arisotura/${REAL_PN}/archive/${REAL_PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${REAL_P}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-2 GPL-2 GPL-3 Unlicense"
+SLOT="0"
+IUSE="+jit +opengl wayland"
+
+RDEPEND="
+ app-arch/libarchive[zstd]
+ dev-qt/qtbase:6[network,opengl,widgets]
+ dev-qt/qtmultimedia:6
+ dev-qt/qtsvg:6
+ media-libs/libsdl2[sound,video]
+ net-libs/enet:=
+ net-libs/libpcap
+ net-libs/libslirp
+ x11-libs/libxkbcommon
+ wayland? (
+ dev-libs/wayland
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ wayland? (
+ kde-frameworks/extra-cmake-modules:0
+ )
+"
+
+# Used for JIT recompiler.
+QA_EXECSTACK="usr/bin/melonDS"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="You need the following files in order to run melonDS:
+- bios7.bin
+- bios9.bin
+- firmware.bin
+- romlist.bin
+Place them in ~/.config/melonDS
+Those files can be extracted from devices or found somewhere on the Internet ;-)"
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DBUILD_SHARED_LIBS="OFF"
+ -DUSE_SYSTEM_LIBSLIRP="ON"
+
+ -DENABLE_JIT="$(usex jit)"
+ -DENABLE_OGLRENDERER="$(usex opengl)"
+ -DENABLE_WAYLAND="$(usex wayland)"
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ tc-export AR
+ cmake_src_compile
+}
+
+src_install() {
+ readme.gentoo_create_doc
+ cmake_src_install
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ readme.gentoo_print_elog
+}