summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-08-17 12:54:18 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-08-17 15:27:20 +0200
commit12abf297056704b7897fce6a507438bc5c658854 (patch)
tree675a8a80b5c79a7036509faf78d34ec5cf1b7799 /games-emulation
parentgames-emulation/melonds: add new enet dependency to live 9999 (diff)
downloadgentoo-12abf297056704b7897fce6a507438bc5c658854.tar.gz
gentoo-12abf297056704b7897fce6a507438bc5c658854.tar.bz2
gentoo-12abf297056704b7897fce6a507438bc5c658854.zip
games-emulation/melonds: bump to 0.9.5_p20240815
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/melonds/Manifest1
-rw-r--r--games-emulation/melonds/melonds-0.9.5_p20240815.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/games-emulation/melonds/Manifest b/games-emulation/melonds/Manifest
index e1e62ba7a142..e3938d87baed 100644
--- a/games-emulation/melonds/Manifest
+++ b/games-emulation/melonds/Manifest
@@ -1 +1,2 @@
DIST melonDS-0.9.5_p20231231.tar.gz 3103695 BLAKE2B 36923cf1e7faf58a05eeac2152faf4ac6387a932fc7accf4be339c752171c6e2d6d7a61d5c9de40e02163a5552701c2f313da85515380e529188260b633445dc SHA512 fe99a37ba347eb6aed470d7b93e4ddbcb32ae81045d64509441ce0fa3b08da31d32b42fef7aca5f01556ae7321fb534ebc369f091e1a8852f4a45eaa7bd941a1
+DIST melonDS-0.9.5_p20240815.tar.gz 3400066 BLAKE2B c2e530ee12e1ba6cb9d7bc1ac233be984a00a9b182b4f8cab3082dad3b6e0449239455f422113ca8efcbcfafd8a4b8bca3b3dc84c79936e467f001b21b90f79d SHA512 7845be503f272aa2b7e070b19c46893274fc3d44ace3ae1ce11e33da8e58766127cb1c89dcb92bd8084f33a8cc7c0241b7416423ec93fe45858211cd69e1766e
diff --git a/games-emulation/melonds/melonds-0.9.5_p20240815.ebuild b/games-emulation/melonds/melonds-0.9.5_p20240815.ebuild
new file mode 100644
index 000000000000..954ab038e91d
--- /dev/null
+++ b/games-emulation/melonds/melonds-0.9.5_p20240815.ebuild
@@ -0,0 +1,99 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+REAL_PN="melonDS"
+REAL_P="${REAL_PN}-${PV}"
+
+[[ "${PV}" == *p20240815 ]] && COMMIT="0e6235a7c4d3e69940a6deae158a5a91dfbfa612"
+
+inherit cmake flag-o-matic readme.gentoo-r1 toolchain-funcs xdg
+
+DESCRIPTION="Nintendo DS emulator, sorta"
+HOMEPAGE="http://melonds.kuribo64.net
+ https://github.com/Arisotura/melonDS"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/Arisotura/${REAL_PN}.git"
+else
+ SRC_URI="https://github.com/Arisotura/${REAL_PN}/archive/${COMMIT}.tar.gz
+ -> ${REAL_P}.tar.gz"
+ S="${WORKDIR}/${REAL_PN}-${COMMIT}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-2 GPL-2 GPL-3 Unlicense"
+SLOT="0"
+IUSE="+jit +opengl wayland"
+
+RDEPEND="
+ app-arch/libarchive
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ media-libs/libsdl2[sound,video]
+ net-libs/enet:=
+ net-libs/libpcap
+ net-libs/libslirp
+ wayland? (
+ dev-libs/wayland
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ wayland? (
+ kde-frameworks/extra-cmake-modules:0
+ )
+"
+
+# used for JIT recompiler
+QA_EXECSTACK="usr/bin/melonDS"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="You need the following files in order to run melonDS:
+- bios7.bin
+- bios9.bin
+- firmware.bin
+- romlist.bin
+Place them in ~/.config/melonDS
+Those files can be extracted from devices or found somewhere on the Internet ;-)"
+
+src_prepare() {
+ filter-lto
+ append-flags -fno-strict-aliasing
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DBUILD_SHARED_LIBS="OFF"
+ -DENABLE_JIT="$(usex jit)"
+ -DENABLE_OGLRENDERER="$(usex opengl)"
+ -DENABLE_WAYLAND="$(usex wayland)"
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ tc-export AR
+ cmake_src_compile
+}
+
+src_install() {
+ readme.gentoo_create_doc
+ cmake_src_install
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ readme.gentoo_print_elog
+}