summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/blackshades
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/blackshades')
-rw-r--r--games-fps/blackshades/Manifest2
-rw-r--r--games-fps/blackshades/blackshades-20070723.ebuild56
-rw-r--r--games-fps/blackshades/files/blackshades-datadir.patch18
-rw-r--r--games-fps/blackshades/files/blackshades-freealut.patch11
-rw-r--r--games-fps/blackshades/files/blackshades-gcc42.patch35
-rw-r--r--games-fps/blackshades/metadata.xml5
6 files changed, 127 insertions, 0 deletions
diff --git a/games-fps/blackshades/Manifest b/games-fps/blackshades/Manifest
new file mode 100644
index 000000000000..4b02f10e8c17
--- /dev/null
+++ b/games-fps/blackshades/Manifest
@@ -0,0 +1,2 @@
+DIST Textures.tar.bz2 340110 SHA256 084f4592e1c83a0ae79a14823f59fe210dc6ae83ff35111972d3b0239b276607 SHA512 42a2a28072972b0919a67a17ab06cf74d6bb611cbf91ff017d72726fa2d01b3c5dec905c6760a199b710eabfff8d980867269d6ad3476096beab5c4edb2cae10 WHIRLPOOL 7e182176a216939fd553f305b3cb49e1c1bc384a157571c0385a0d9a74a2ea19bbaca618e6ad8f0591940f564bd0f43b408ad75657ff2e0cf73ac6b14348b52b
+DIST blackshades-20070723.tar.bz2 761669 SHA256 2fbd1ed3778a834010fe4de94063149b60461d6e9d155b281747c2e14fc30056 SHA512 9477c59d685227650980c16aeb59f567764bc983c01da4e256b2ec582b5a063ef89222eb4ab0d42552bf6a4ffd95ba270229800decc9ba7a9b289f093c5b9c61 WHIRLPOOL 2eed49d46090509c4ddd1638b6066c7017453beae646d8dd7e42d6f54d8f8195b0a7f07b7ec22164f952acc0902e2a4c0dcb915dae8cd3e46567a14e68a92f02
diff --git a/games-fps/blackshades/blackshades-20070723.ebuild b/games-fps/blackshades/blackshades-20070723.ebuild
new file mode 100644
index 000000000000..068814f5e360
--- /dev/null
+++ b/games-fps/blackshades/blackshades-20070723.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="you control a psychic bodyguard, and try to protect the VIP"
+HOMEPAGE="http://www.wolfire.com/blackshades.html
+ http://www.icculus.org/blackshades/"
+SRC_URI="http://filesingularity.timedoctor.org/Textures.tar.bz2
+ mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="blackshades"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/freealut
+ media-libs/libsdl"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ rm -rf Data/Textures
+ rm -f ../Textures/{,Blood/}._*
+ mv -f ../Textures Data || die "mv failed"
+ epatch "${FILESDIR}"/${PN}-datadir.patch
+ sed -i \
+ -e "s/-O2 \(-Wall\) -g/${CXXFLAGS} \1/" \
+ -e "/^LINKER/s:$: ${LDFLAGS}:" \
+ Makefile \
+ || die "sed Makefile failed"
+ sed -i "s:@DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ Source/Main.cpp \
+ || die "sed Main.cpp failed"
+}
+
+src_compile() {
+ emake bindir
+ emake
+}
+
+src_install() {
+ newgamesbin objs/blackshades ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r Data
+ dodoc IF_THIS_IS_A_README_YOU_HAVE_WON Readme TODO uDevGame_Readme
+ make_desktop_entry ${PN} "Black Shades"
+ prepgamesdirs
+}
diff --git a/games-fps/blackshades/files/blackshades-datadir.patch b/games-fps/blackshades/files/blackshades-datadir.patch
new file mode 100644
index 000000000000..0050271705a2
--- /dev/null
+++ b/games-fps/blackshades/files/blackshades-datadir.patch
@@ -0,0 +1,18 @@
+--- Source/Main.cpp
++++ Source/Main.cpp
+@@ -1,6 +1,7 @@
+ /********************> Headers <*****/
+
+ #include "Game.h"
++#include <unistd.h>
+
+
+
+@@ -17,6 +18,7 @@
+ int main( int argc, char *argv[] )
+
+ {
++ chdir("@DATADIR@");
+
+
+ #ifdef OS9
diff --git a/games-fps/blackshades/files/blackshades-freealut.patch b/games-fps/blackshades/files/blackshades-freealut.patch
new file mode 100644
index 000000000000..4c0324fa3b06
--- /dev/null
+++ b/games-fps/blackshades/files/blackshades-freealut.patch
@@ -0,0 +1,11 @@
+--- Makefile
++++ Makefile
+@@ -8,7 +8,7 @@
+
+ CFLAGS := -O2 -Wall -g $(shell sdl-config --cflags) -I$(SRCDIR) -include Source/Support.h
+ CXXFLAGS := $(CFLAGS)
+-LDFLAGS := $(shell sdl-config --libs) -lGL -lGLU -lopenal # -framework QuickTime
++LDFLAGS := $(shell sdl-config --libs) -lGL -lGLU -lopenal -lalut # -framework QuickTime
+
+ # Don't want ogg?
+ #CFLAGS += -DNOOGG
diff --git a/games-fps/blackshades/files/blackshades-gcc42.patch b/games-fps/blackshades/files/blackshades-gcc42.patch
new file mode 100644
index 000000000000..fecf8f67d82c
--- /dev/null
+++ b/games-fps/blackshades/files/blackshades-gcc42.patch
@@ -0,0 +1,35 @@
+--- Source/GameDraw.cpp
++++ Source/GameDraw.cpp
+@@ -36,7 +36,7 @@
+
+ /*********************> DrawGLScene() <*****/
+
+-int Game::DrawGLScene(GLvoid)
++int Game::DrawGLScene(void)
+
+ {
+
+--- Source/Game.h
++++ Source/Game.h
+@@ -75,8 +75,8 @@
+
+ //GL functions
+ GLvoid ReSizeGLScene(float fov, float near);
+- int DrawGLScene(GLvoid);
+- int InitGL(GLvoid);
++ int DrawGLScene(void);
++ int InitGL(void);
+ void LoadingScreen(float percent);
+
+ //Game Functions
+--- Source/GameInitDispose.cpp
++++ Source/GameInitDispose.cpp
+@@ -3913,7 +3913,7 @@
+
+
+
+-int Game::InitGL(GLvoid)
++int Game::InitGL(void)
+
+ {
+
diff --git a/games-fps/blackshades/metadata.xml b/games-fps/blackshades/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-fps/blackshades/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>