summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/4stattack
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/4stattack')
-rw-r--r--games-puzzle/4stattack/4stattack-2.1.4.ebuild39
-rw-r--r--games-puzzle/4stattack/Manifest1
-rw-r--r--games-puzzle/4stattack/files/4stattack-2.1.4-gentoo.diff21
-rw-r--r--games-puzzle/4stattack/metadata.xml8
4 files changed, 69 insertions, 0 deletions
diff --git a/games-puzzle/4stattack/4stattack-2.1.4.ebuild b/games-puzzle/4stattack/4stattack-2.1.4.ebuild
new file mode 100644
index 000000000000..885ac94d922b
--- /dev/null
+++ b/games-puzzle/4stattack/4stattack-2.1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Connect-4 game, single or network multiplayer"
+HOMEPAGE="http://forcedattack.sourceforge.net/"
+SRC_URI="mirror://sourceforge/forcedattack/4stAttack-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-python/pygame"
+
+S=${WORKDIR}/4stAttack-${PV}
+
+src_prepare() {
+ # move the doc files aside so it's easier to install the game files
+ mv README.txt credits.txt changelog.txt ..
+ rm -f GPL version~
+
+ # This patch makes the game save settings in $HOME
+ epatch "${FILESDIR}"/${P}-gentoo.diff
+}
+
+src_install() {
+ games_make_wrapper ${PN} "python ${PN}.py" "${GAMES_DATADIR}"/${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r *
+ newicon kde/icons/48x48/forcedattack2.png ${PN}.png
+ make_desktop_entry ${PN} "4st Attack 2"
+ dodoc ../{README.txt,credits.txt,changelog.txt}
+ prepgamesdirs
+}
diff --git a/games-puzzle/4stattack/Manifest b/games-puzzle/4stattack/Manifest
new file mode 100644
index 000000000000..6db450e8ec01
--- /dev/null
+++ b/games-puzzle/4stattack/Manifest
@@ -0,0 +1 @@
+DIST 4stAttack-2.1.4.tar.gz 1828247 SHA256 196c553fd3dbda8b2c2a07a9b0cbacf4f067712498f909d2823161e7d0b289e6 SHA512 4819c0915bfe47bb965ea39d49fa007fb18cfa965b15e5e72a4b0ac3be8a03c616d9438c8dedd960ee257e44b48f98f75ced6bed5bfc77f3366328c797b30f3c WHIRLPOOL 439d05b5208821d18b6976f055de32521283ee737832bf80c4eeea1f62bb334cc72b43b360b09f9cb0da42e8310e54e078ff097432e24ebd3c5ae74ddad1ac99
diff --git a/games-puzzle/4stattack/files/4stattack-2.1.4-gentoo.diff b/games-puzzle/4stattack/files/4stattack-2.1.4-gentoo.diff
new file mode 100644
index 000000000000..be7d32ed3ff2
--- /dev/null
+++ b/games-puzzle/4stattack/files/4stattack-2.1.4-gentoo.diff
@@ -0,0 +1,21 @@
+--- 4stattack.py
++++ 4stattack.py
+@@ -28,6 +28,9 @@
+ images = None
+ screen = None
+
++f = os.path.expanduser('~/.4stattackrc')
++if not os.path.exists(f):
++ os.system('cp settings.ini %s' % f)
+
+ def playMusic(datadir):
+ if pygame.mixer.get_init():
+@@ -78,7 +81,7 @@
+ if options.has_key('-ini'):
+ ini_settings = IniSettings(options['-ini'])
+ else:
+- ini_settings = IniSettings('settings.ini')
++ ini_settings = IniSettings(os.path.expanduser('~/.4stattackrc'))
+
+ settings = ini_settings.settings
+
diff --git a/games-puzzle/4stattack/metadata.xml b/games-puzzle/4stattack/metadata.xml
new file mode 100644
index 000000000000..8a762d2d0fc2
--- /dev/null
+++ b/games-puzzle/4stattack/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">forcedattack</remote-id>
+ </upstream>
+</pkgmetadata>