summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/galaxis
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/galaxis')
-rw-r--r--games-puzzle/galaxis/Manifest1
-rw-r--r--games-puzzle/galaxis/files/galaxis-1.7-gentoo.patch83
-rw-r--r--games-puzzle/galaxis/files/galaxis-1.8-gentoo.patch60
-rw-r--r--games-puzzle/galaxis/galaxis-1.8.ebuild27
-rw-r--r--games-puzzle/galaxis/metadata.xml5
5 files changed, 176 insertions, 0 deletions
diff --git a/games-puzzle/galaxis/Manifest b/games-puzzle/galaxis/Manifest
new file mode 100644
index 000000000000..1b540df1bb83
--- /dev/null
+++ b/games-puzzle/galaxis/Manifest
@@ -0,0 +1 @@
+DIST galaxis-1.8.tar.gz 8962 SHA256 bc36c7e5b1e1d96e5a8c6cdb117b3891833a99e99df709c5531c7d44009a8adc SHA512 9d4c7447827fea333ddec8a289d5d6415777379c7aab53fc2088418051f3a38c8abeceff2e8ba0472f792fac457345f2307b3f51c8366aa0b9affa37c3eee05f WHIRLPOOL 719323349e747473501fb4bd737cb7db8b719dd22e5dfc3d0f7acb9402618064206311101a466fa37037381781094b8c90348171e6b8d2f04b04539e96af72b0
diff --git a/games-puzzle/galaxis/files/galaxis-1.7-gentoo.patch b/games-puzzle/galaxis/files/galaxis-1.7-gentoo.patch
new file mode 100644
index 000000000000..3153291d3f4f
--- /dev/null
+++ b/games-puzzle/galaxis/files/galaxis-1.7-gentoo.patch
@@ -0,0 +1,83 @@
+diff -ru galaxis-1.7.orig/Makefile galaxis-1.7/Makefile
+--- galaxis-1.7.orig/Makefile 2003-12-29 04:09:53.000000000 -0500
++++ galaxis-1.7/Makefile 2010-10-18 13:08:43.929375025 -0400
+@@ -3,9 +3,8 @@
+ VERS=$(shell sed <galaxis.spec -n -e '/Version: \(.*\)/s//\1/p')
+
+ # Flags for use with the Linux ncurses package (recommended)
+-CFLAGS = -g -DNDEBUG # -I/usr/local/include -L/usr/local/lib
++CFLAGS += -DNDEBUG # -I/usr/local/include -L/usr/local/lib
+ TERMLIB = -lncurses
+-CC = gcc
+
+ # Flags for use with stock curses
+ #CFLAGS = -DNDEBUG
+@@ -13,7 +12,7 @@
+ #CC = gcc
+
+ galaxis: galaxis.c
+- $(CC) $(CFLAGS) -o galaxis galaxis.c $(TERMLIB)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o galaxis galaxis.c $(TERMLIB)
+
+ galaxis.6: galaxis.xml
+ xmlto man galaxis.xml
+diff -ru galaxis-1.7.orig/galaxis.c galaxis-1.7/galaxis.c
+--- galaxis-1.7.orig/galaxis.c 2003-12-26 23:19:20.000000000 -0500
++++ galaxis-1.7/galaxis.c 2010-10-18 13:10:03.575307583 -0400
+@@ -8,6 +8,10 @@
+ #define _POSIX_SOURCE
+
+ #include <stdio.h>
++#include <stdlib.h>
++#include <unistd.h>
++#include <time.h>
++#include <string.h>
+ #include <termios.h>
+ #include <curses.h>
+ #include <signal.h>
+@@ -29,7 +33,6 @@
+ extern long lrand48();
+ extern void srand48();
+ #define bzero(s, n) (void)memset((char *)(s), '\0', n)
+-extern char *memset();
+ /*
+ * Try this if ungetch() fails to resolve.
+ *
+@@ -167,16 +170,17 @@
+ }
+
+ /* VARARGS1 */
+-static void prompt(f, s)
++static void prompt(s)
+ /* print a message at the prompt line */
+-char *f, *s;
++char *s;
+ {
+ (void) move(PROMPTLINE, 0);
+ (void) clrtoeol();
+- (void) printw(f, s);
++ (void) printw("%s", s);
+ (void) refresh();
+ }
+
++#if 0
+ static void error(s)
+ char *s;
+ {
+@@ -188,6 +192,7 @@
+ (void) beep();
+ }
+ }
++#endif
+
+ static int rnd(n)
+ int n;
+@@ -647,7 +652,7 @@
+ }
+ }
+
+-main(argc, argv)
++int main(argc, argv)
+ int argc;
+ char *argv[];
+ {
diff --git a/games-puzzle/galaxis/files/galaxis-1.8-gentoo.patch b/games-puzzle/galaxis/files/galaxis-1.8-gentoo.patch
new file mode 100644
index 000000000000..abee05096288
--- /dev/null
+++ b/games-puzzle/galaxis/files/galaxis-1.8-gentoo.patch
@@ -0,0 +1,60 @@
+diff -ru galaxis-1.8.orig/Makefile galaxis-1.8/Makefile
+--- galaxis-1.8.orig/Makefile 2010-10-19 09:48:58.000000000 -0400
++++ galaxis-1.8/Makefile 2010-10-20 04:04:49.246650551 -0400
+@@ -3,9 +3,8 @@
+ VERS=$(shell sed <galaxis.spec -n -e '/Version: \(.*\)/s//\1/p')
+
+ # Flags for use with the Linux ncurses package (recommended)
+-CFLAGS = -g -DNDEBUG # -I/usr/local/include -L/usr/local/lib
++CFLAGS += -DNDEBUG # -I/usr/local/include -L/usr/local/lib
+ TERMLIB = -lncurses
+-CC = gcc
+
+ # Flags for use with stock curses
+ #CFLAGS = -DNDEBUG
+@@ -13,7 +12,7 @@
+ #CC = gcc
+
+ galaxis: galaxis.c
+- $(CC) $(CFLAGS) -o galaxis galaxis.c $(TERMLIB)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o galaxis galaxis.c $(TERMLIB)
+
+ galaxis.6: galaxis.xml
+ xmlto man galaxis.xml
+diff -ru galaxis-1.8.orig/galaxis.c galaxis-1.8/galaxis.c
+--- galaxis-1.8.orig/galaxis.c 2010-10-13 06:13:31.000000000 -0400
++++ galaxis-1.8/galaxis.c 2010-10-20 04:05:30.036888771 -0400
+@@ -8,6 +8,8 @@
+ #define _POSIX_SOURCE
+
+ #include <stdio.h>
++#include <unistd.h>
++#include <time.h>
+ #include <termios.h>
+ #include <curses.h>
+ #include <signal.h>
+@@ -176,6 +177,7 @@
+ (void) refresh();
+ }
+
++#if 0
+ static void error(char *s)
+ {
+ (void) move(PROMPTLINE + 2, 0);
+@@ -186,6 +188,7 @@
+ (void) beep();
+ }
+ }
++#endif
+
+ static int rnd(int n)
+ {
+@@ -644,7 +647,7 @@
+ }
+ }
+
+-main(argc, argv)
++int main(argc, argv)
+ int argc;
+ char *argv[];
+ {
diff --git a/games-puzzle/galaxis/galaxis-1.8.ebuild b/games-puzzle/galaxis/galaxis-1.8.ebuild
new file mode 100644
index 000000000000..9aeb8cdb89c8
--- /dev/null
+++ b/games-puzzle/galaxis/galaxis-1.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit games
+
+DESCRIPTION="A UNIX-hosted, curses-based clone of the nifty little Macintosh freeware game Galaxis"
+HOMEPAGE="http://www.catb.org/~esr/galaxis/"
+SRC_URI="http://www.catb.org/~esr/galaxis/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.3"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_install() {
+ dogamesbin galaxis
+ doman galaxis.6
+ dodoc README
+ prepgamesdirs
+}
diff --git a/games-puzzle/galaxis/metadata.xml b/games-puzzle/galaxis/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/galaxis/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>