summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 19:35:27 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:12:10 +0100
commit8122ea6f8b26d76cce8fa2f11e1636b7f1dae198 (patch)
treeeffe9d9ff6ff6f09ac74c65b0f5b80d71e6fe81a /games-puzzle
parentgames-emulation/nestra: port to EAPI 7 (diff)
downloadgentoo-8122ea6f8b26d76cce8fa2f11e1636b7f1dae198.tar.gz
gentoo-8122ea6f8b26d76cce8fa2f11e1636b7f1dae198.tar.bz2
gentoo-8122ea6f8b26d76cce8fa2f11e1636b7f1dae198.zip
games-puzzle/groundhog: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/groundhog/groundhog-1.4-r1.ebuild24
1 files changed, 16 insertions, 8 deletions
diff --git a/games-puzzle/groundhog/groundhog-1.4-r1.ebuild b/games-puzzle/groundhog/groundhog-1.4-r1.ebuild
index ba93616b6702..5fc37b168a5d 100644
--- a/games-puzzle/groundhog/groundhog-1.4-r1.ebuild
+++ b/games-puzzle/groundhog/groundhog-1.4-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit desktop epatch autotools
+EAPI=7
+
+inherit autotools desktop
DEB_VER="9"
DESCRIPTION="Put the balls in the pockets of the same color by manipulating a maze of tubes"
@@ -26,16 +27,22 @@ DEPEND="${RDEPEND}
src_prepare() {
default
- cd "${WORKDIR}"
- epatch groundhog_${PV}-${DEB_VER}.diff
- cd "${S}"
+
+ cd "${WORKDIR}" || die
+ eapply groundhog_${PV}-${DEB_VER}.diff
+
+ cd "${S}" || die
sed -e "s:groundhog-1.4/::" -i \
- debian/patches/sv.po.patch || die
+ "${WORKDIR}"/debian/patches/sv.po.patch || die
+
eapply \
- $(sed -e 's:^:debian/patches/:' debian/patches/series) \
+ $(sed -e "s:^:${WORKDIR}/debian/patches/:" "${WORKDIR}"/debian/patches/series) \
"${FILESDIR}"/${P}-flags.patch
+
mv configure.in configure.ac || die
+
AT_M4DIR="m4" eautoreconf
+
sed -i 's:$(localedir):/usr/share/locale:' \
$(find . -name 'Makefile.in*') || die
}
@@ -46,6 +53,7 @@ src_configure() {
src_install() {
default
+
doicon src/pixmaps/${PN}.xpm
make_desktop_entry ${PN} "Groundhog" /usr/share/pixmaps/${PN}.xpm
}