summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/a-bird-story
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/a-bird-story')
-rw-r--r--games-rpg/a-bird-story/Manifest1
-rw-r--r--games-rpg/a-bird-story/a-bird-story-20141106.ebuild102
-rw-r--r--games-rpg/a-bird-story/metadata.xml12
3 files changed, 115 insertions, 0 deletions
diff --git a/games-rpg/a-bird-story/Manifest b/games-rpg/a-bird-story/Manifest
new file mode 100644
index 000000000000..d8e81a6a9588
--- /dev/null
+++ b/games-rpg/a-bird-story/Manifest
@@ -0,0 +1 @@
+DIST ABirdStory-2014-11-06.sh 163620225 SHA256 b8d390c8325d31b287a87ee9f3475a2e454473196247a17fef1ede80744da30e SHA512 1787d3267fb4ed71845cc614842fb6bfa6713c3d9ebeb4b3bac922776243bfc3ae3d3dd94e3a5ab871d67489fda8c87c3a3fb71dcac4066c49cecc702a81bbd9 WHIRLPOOL 90bc002b38ae16482b8849b38db58b20dc5863aca841b02322c4f3abf279a785625454ade7daef5525a720d88a68cf5627613b75118d1b254fdb249a800ecfc5
diff --git a/games-rpg/a-bird-story/a-bird-story-20141106.ebuild b/games-rpg/a-bird-story/a-bird-story-20141106.ebuild
new file mode 100644
index 000000000000..0ece9a80d5d0
--- /dev/null
+++ b/games-rpg/a-bird-story/a-bird-story-20141106.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils unpacker multilib gnome2-utils games
+MY_PN=ABirdStory
+DESCRIPTION="Indie adventure short of a boy's memories, dream, and imagination"
+HOMEPAGE="http://freebirdgames.com/games/a-bird-story/"
+SRC_URI="${MY_PN}-${PV:0:4}-${PV:4:2}-${PV:6:2}.sh"
+
+# missing: SIL, Xiph
+# physfs ZLIB
+# sdl-sound LGPL-2.1
+LICENSE="all-rights-reserved BSD OFL-1.1 LGPL-2.1 ZLIB bundled-libs? ( FTL GPL-2 MIT ( || ( Ruby-BSD BSD-2 ) ) )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bundled-libs"
+RESTRICT="fetch bindist splitdebug"
+
+QA_PREBUILT="${GAMES_PREFIX_OPT}/${PN}/${MY_PN}.bin*"
+if [[ ${ARCH} == "amd64" ]] ; then
+ QA_PREBUILT="${QA_PREBUILT} ${GAMES_PREFIX_OPT}/${PN}/lib64/*"
+else
+ QA_PREBUILT="${QA_PREBUILT} ${GAMES_PREFIX_OPT}/${PN}/lib/*"
+fi
+
+RDEPEND="
+ !bundled-libs? (
+ dev-games/physfs
+ dev-lang/ruby:2.1
+ dev-libs/libsigc++:2
+ >=media-libs/libsdl2-2.0.1[X,joystick,opengl,sound,threads,video]
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-ttf
+ sys-libs/zlib
+ x11-libs/pixman
+ )
+ virtual/opengl"
+
+S=${WORKDIR}/data
+
+pkg_nofetch() {
+ einfo
+ einfo "Please buy & download \"${SRC_URI}\" from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move/link it to \"${DISTDIR}\""
+ einfo
+}
+
+src_unpack() {
+ # mojo stuff inside makeself archive, unpack_makeself fails
+ local lastline=$(( $(grep -a -h -n -m 1 -F -e "Extra newline, because in very rare cases (OpenSolaris) stub is directly added after script" "${DISTDIR}/${A}" | cut -d':' -f1) + 1 ))
+ [[ ${lastline} ]] || die "no last line"
+ local offset=$(head -n ${lastline} "${DISTDIR}/${A}" | wc -c)
+ [[ ${offset} ]] || die "no offset"
+ dd ibs=${offset} skip=1 if="${DISTDIR}/${A}" of="${T}"/bird.zip || die
+ unpack_zip "${T}"/bird.zip
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ local arch=$(usex amd64 "x86_64" "x86")
+
+ insinto "${dir}"
+ doins -r noarch/*
+
+ exeinto "${dir}"
+ doexe ${arch}/${MY_PN}.$(usex amd64 "amd64" "x86")
+
+ exeinto "${dir}/$(get_libdir)"
+ if use bundled-libs ; then
+ doexe ${arch}/$(get_libdir)/*
+ else
+ doexe ${arch}/$(get_libdir)/{libsteam_api.so,libphysfs.so.1,libSDL_sound-1.0.so.1}
+ fi
+
+ games_make_wrapper ${PN} \
+ "./${MY_PN}.$(usex amd64 "amd64" "x86")" \
+ "${dir}" "${dir}/$(get_libdir)"
+ make_desktop_entry ${PN} "A bird story"
+ newicon -s 48 noarch/icon.png ${PN}.png
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-rpg/a-bird-story/metadata.xml b/games-rpg/a-bird-story/metadata.xml
new file mode 100644
index 000000000000..ef31c088e796
--- /dev/null
+++ b/games-rpg/a-bird-story/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <maintainer>
+ <email>hasufell@gentoo.org</email>
+ <name>Julian Ospald</name>
+ </maintainer>
+ <use>
+ <flag name='bundled-libs'>Use bundled libraries</flag>
+ </use>
+</pkgmetadata>