summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-sports/dustrac
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-sports/dustrac')
-rw-r--r--games-sports/dustrac/Manifest1
-rw-r--r--games-sports/dustrac/dustrac-1.11.0.ebuild70
-rw-r--r--games-sports/dustrac/files/dustrac-1.11.0-cmake.patch23
-rw-r--r--games-sports/dustrac/metadata.xml15
4 files changed, 109 insertions, 0 deletions
diff --git a/games-sports/dustrac/Manifest b/games-sports/dustrac/Manifest
new file mode 100644
index 000000000000..6f760fb66413
--- /dev/null
+++ b/games-sports/dustrac/Manifest
@@ -0,0 +1 @@
+DIST dustrac-1.11.0.tar.gz 27505282 SHA256 3f1cca3d431152eb2e7702c772f744a216a47c4e0f44fa193aa62ba227e15e43 SHA512 af67b76a815543d41cf8e5681ede11bfd63a2d6be7e4a21986d495d77b2673f5a145bb1c9cd5237d2caf64a4e77f221ae48b97a38a883dcd4e5bb0ef8c55f839 WHIRLPOOL fb9dea84a5d2b771124d5ac933646fbc228078916a29cffd9330f39cb31a825379d5a40000a96909e270c739ceea5725b8798969eff3193142897e1ba659526a
diff --git a/games-sports/dustrac/dustrac-1.11.0.ebuild b/games-sports/dustrac/dustrac-1.11.0.ebuild
new file mode 100644
index 000000000000..e34e5f7106c8
--- /dev/null
+++ b/games-sports/dustrac/dustrac-1.11.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils cmake-utils games
+
+DESCRIPTION="Tile-based, cross-platform 2D racing game"
+HOMEPAGE="http://dustrac.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dustrac/${P}.tar.gz"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtxml:5
+ dev-qt/linguist-tools:5
+ media-libs/libvorbis
+ media-libs/openal
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ dev-qt/qttest:5
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cmake.patch
+}
+
+src_configure() {
+ # -DGLES=ON didn't build for me but maybe just need use flags on some QT package?
+ # Maybe add a local gles use flag
+ local mycmakeargs=(
+ -DReleaseBuild=ON
+ -DDATA_PATH="${GAMES_DATADIR}/${PN}"
+ -DBIN_PATH="${GAMES_BINDIR}"
+ -DDOC_PATH=/usr/share/doc/${PF}
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ dosym /usr/share/fonts/ubuntu-font-family/UbuntuMono-B.ttf "${GAMES_DATADIR}/${PN}/fonts/UbuntuMono-B.ttf"
+ dosym /usr/share/fonts/ubuntu-font-family/UbuntuMono-R.ttf "${GAMES_DATADIR}/${PN}/fonts/UbuntuMono-R.ttf"
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-sports/dustrac/files/dustrac-1.11.0-cmake.patch b/games-sports/dustrac/files/dustrac-1.11.0-cmake.patch
new file mode 100644
index 000000000000..6f497e4969ef
--- /dev/null
+++ b/games-sports/dustrac/files/dustrac-1.11.0-cmake.patch
@@ -0,0 +1,23 @@
+--- dustrac-1.11.0.orig/CMakeLists.txt
++++ dustrac-1.11.0/CMakeLists.txt
+@@ -68,8 +68,7 @@
+ endif()
+
+ if(CMAKE_COMPILER_IS_GNUCXX OR MINGW OR "${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
+- add_compile_options(-std=c++11 -W -Wall -O3 -pedantic)
+- add_compile_options(-fomit-frame-pointer -finline-functions -ffast-math)
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -W -Wall -fomit-frame-pointer -finline-functions")
+ elseif(MSVC)
+ add_definitions(-DNOMINMAX)
+ endif()
+--- dustrac-1.11.0.orig/InstallLinux.cmake
++++ dustrac-1.11.0/InstallLinux.cmake
+@@ -58,7 +58,7 @@
+ install(FILES data/fonts.conf DESTINATION ${DATA_PATH})
+ install(FILES data/meshes.conf DESTINATION ${DATA_PATH})
+ install(FILES data/surfaces.conf DESTINATION ${DATA_PATH})
+- install(FILES AUTHORS CHANGELOG COPYING README DESTINATION ${DOC_PATH})
++ install(FILES AUTHORS CHANGELOG README DESTINATION ${DOC_PATH})
+ install(DIRECTORY data/images DESTINATION ${DATA_PATH} FILES_MATCHING PATTERN "*.jpg")
+ install(DIRECTORY data/images DESTINATION ${DATA_PATH} FILES_MATCHING PATTERN "*.png")
+ install(DIRECTORY data/levels DESTINATION ${DATA_PATH} FILES_MATCHING PATTERN "*.trk")
diff --git a/games-sports/dustrac/metadata.xml b/games-sports/dustrac/metadata.xml
new file mode 100644
index 000000000000..c552dd293090
--- /dev/null
+++ b/games-sports/dustrac/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription lang="en">
+ Dust Racing (Dustrac) is a tile-based, cross-platform 2D racing
+ game written in Qt (C++) and OpenGL. Dust Racing comes with a
+ Qt-based level editor for easy level creation. A custom engine,
+ MiniCore, is used for physics modeling. Dust Racing 2D is
+ inspired by Super Cars and Slicks’n Slide.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">dustrac</remote-id>
+ </upstream>
+</pkgmetadata>