summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2021-07-07 23:47:37 +0100
committerIonen Wolkens <ionen@gentoo.org>2021-07-08 06:13:20 -0400
commit7112bef07ba3aa74123af01328c7a7a1088a5fd3 (patch)
tree24f4471af23a35fd34aa13d42b9ef72305273543 /games-sports/stormbaancoureur/stormbaancoureur-2.1.6-r2.ebuild
parentnet-p2p/mktorrent: bump snapshot versionm, respect CC (diff)
downloadgentoo-7112bef07ba3aa74123af01328c7a7a1088a5fd3.tar.gz
gentoo-7112bef07ba3aa74123af01328c7a7a1088a5fd3.tar.bz2
gentoo-7112bef07ba3aa74123af01328c7a7a1088a5fd3.zip
games-sports/stormbaancoureur: bump EAPI, fix build
Closes: https://bugs.gentoo.org/739386 Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-sports/stormbaancoureur/stormbaancoureur-2.1.6-r2.ebuild')
-rw-r--r--games-sports/stormbaancoureur/stormbaancoureur-2.1.6-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-sports/stormbaancoureur/stormbaancoureur-2.1.6-r2.ebuild b/games-sports/stormbaancoureur/stormbaancoureur-2.1.6-r2.ebuild
new file mode 100644
index 000000000000..a1239ecaa187
--- /dev/null
+++ b/games-sports/stormbaancoureur/stormbaancoureur-2.1.6-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop toolchain-funcs
+
+DESCRIPTION="Simulated obstacle course for automobiles"
+HOMEPAGE="http://www.stolk.org/stormbaancoureur/"
+SRC_URI="http://www.stolk.org/stormbaancoureur/download/${P}.tar.gz"
+S="${WORKDIR}/${P}/src-stormbaancoureur"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-games/ode-0.8[-double-precision]
+ media-libs/alsa-lib
+ media-libs/freeglut
+ >=media-libs/plib-1.8.4
+ virtual/glu
+ virtual/opengl"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-clang.patch
+)
+
+src_prepare() {
+ default
+
+ sed -ie "s:GENTOODIR:/usr/share/${PN}:" main.cxx || die
+}
+
+src_compile() {
+ tc-export CXX
+ emake LIBDIRNAME=$(get_libdir)
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins -r images/ models/ sounds/ shaders/
+ dodoc JOYSTICKS README TODO
+ make_desktop_entry ${PN} "Stormbaan Coureur"
+}