summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-14 20:28:48 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-14 20:45:37 +0100
commitc6013816a4dbd2de8e6a3776c29f621f4c9c341f (patch)
treea2d7bfab262883b9323f997afe36c44e80630bdb /gnome-extra/gnome-boxes
parentgnome-base/libgtop: fix metadata (diff)
downloadgentoo-c6013816a4dbd2de8e6a3776c29f621f4c9c341f.tar.gz
gentoo-c6013816a4dbd2de8e6a3776c29f621f4c9c341f.tar.bz2
gentoo-c6013816a4dbd2de8e6a3776c29f621f4c9c341f.zip
gnome-extra/gnome-boxes: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'gnome-extra/gnome-boxes')
-rw-r--r--gnome-extra/gnome-boxes/Manifest1
-rw-r--r--gnome-extra/gnome-boxes/gnome-boxes-3.18.1.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/gnome-extra/gnome-boxes/Manifest b/gnome-extra/gnome-boxes/Manifest
index 6ecd51f2ce6e..9368bd6599d1 100644
--- a/gnome-extra/gnome-boxes/Manifest
+++ b/gnome-extra/gnome-boxes/Manifest
@@ -1,2 +1,3 @@
DIST gnome-boxes-3.14.3.1.tar.xz 1363088 SHA256 048df41ce1bcece1d89dfddcb571ed17dfa7f614929cd63f3079d14c66c10f24 SHA512 c714ff854f63832a2d0b6660378d36d5dfd99ece584a12ebe066cb58da6ee374287069d23a28f1966c343e68b5db25dbac5651031316bbe464f37a0746bf5822 WHIRLPOOL 18ec809438a64d7fa8e96a3bff9beece05c9312e2920bc5c10ca9efd8669b9b0eb1ace403d5252729da23735f3f9aec3f58be5a269df56a18bb9ca11e6f7d137
DIST gnome-boxes-3.16.2.tar.xz 1604664 SHA256 f5fecb1ba0769e2a3dbec31e6149fffbcbd59946e4dbab31fb3ec28a16e41995 SHA512 40fcb79cedfa070e6beed905ec814caff2764361a9b5205e68dbe8b6bbdc737a550d1c1695446ac053813b77e24bb2a6087a2eca352c9d28d13c0655142454c0 WHIRLPOOL 37cfbaafdaa724eaee10485415dac5e16161a41bfbdca83f86b806bd3f0b6143900e30154939db481e546b0bd87db8d32e505f482e1bd1a0f81ec051936be7b5
+DIST gnome-boxes-3.18.1.tar.xz 1655760 SHA256 0235d7f76cf3faa3889b302c743d608759e84506657ed4e374592c39f768fb2b SHA512 eb8cd1c4dde02435f8ac0c02181e37e5523a2d67b5a2196d0ba6a1af798392a59ac3706879331cc969f8e74ec476b1be478592413383683a316e95934e02087b WHIRLPOOL 68c1dac4545e71d8902d3b2efaa6cbd074ed7f97fa5cc2263fe2e28b9e166f439208f78fc179f375b574e70e81895b82fd59be310638bdab984c2ffb7e8da60b
diff --git a/gnome-extra/gnome-boxes/gnome-boxes-3.18.1.ebuild b/gnome-extra/gnome-boxes/gnome-boxes-3.18.1.ebuild
new file mode 100644
index 000000000000..0531741771b7
--- /dev/null
+++ b/gnome-extra/gnome-boxes/gnome-boxes-3.18.1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION="0.28"
+
+inherit linux-info gnome2 readme.gentoo vala
+
+DESCRIPTION="Simple GNOME 3 application to access remote or virtual systems"
+HOMEPAGE="https://wiki.gnome.org/Apps/Boxes"
+
+LICENSE="LGPL-2"
+SLOT="0"
+
+# We force 'bindist' due to licenses from gnome-boxes-nonfree
+IUSE="smartcard usbredir" #bindist
+KEYWORDS="~amd64" # qemu-kvm[spice] is 64bit-only
+
+# NOTE: sys-fs/* stuff is called via exec()
+# FIXME: ovirt is not available in tree
+# FIXME: use vala.eclass but only because of libgd not being able
+# to use its pre-generated files so do not copy all the
+# vala deps like live ebuild has.
+RDEPEND="
+ >=app-arch/libarchive-3:=
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/gobject-introspection-0.9.6:=
+ >=dev-libs/libxml2-2.7.8:2
+ >=sys-libs/libosinfo-0.2.12
+ >=app-emulation/qemu-1.3.1[spice,smartcard?,usbredir?]
+ >=app-emulation/libvirt-0.9.3[libvirtd,qemu]
+ >=app-emulation/libvirt-glib-0.2.2
+ >=x11-libs/gtk+-3.13.2:3
+ >=net-libs/gtk-vnc-0.4.4[gtk3]
+ >=net-misc/spice-gtk-0.27[gtk3,smartcard?,usbredir?]
+ virtual/libusb:1
+
+ >=app-misc/tracker-0.16:0=[iso]
+
+ >=sys-apps/util-linux-2.20
+ >=net-libs/libsoup-2.38:2.4
+
+ sys-fs/fuse
+ sys-fs/fuseiso
+ sys-fs/mtools
+ virtual/libgudev:=
+"
+# !bindist? ( gnome-extra/gnome-boxes-nonfree )
+
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ app-text/yelp-tools
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="Before running gnome-boxes, you will need to load the KVM modules.
+If you have an Intel Processor, run:
+# modprobe kvm-intel
+
+If you have an AMD Processor, run:
+# modprobe kvm-amd"
+
+pkg_pretend() {
+ linux-info_get_any_version
+
+ if linux_config_exists; then
+ if ! { linux_chkconfig_present KVM_AMD || \
+ linux_chkconfig_present KVM_INTEL; }; then
+ ewarn "You need KVM support in your kernel to use GNOME Boxes!"
+ fi
+ fi
+}
+
+src_prepare() {
+ # Do not change CFLAGS, wondering about VALA ones but appears to be
+ # needed as noted in configure comments below
+ sed 's/CFLAGS="$CFLAGS -O0 -ggdb3"//' -i configure{.ac,} || die
+
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # debug needed for splitdebug proper behavior (cardoe), bug #????
+ gnome2_src_configure \
+ --enable-debug \
+ --disable-strict-cc \
+ $(use_enable usbredir) \
+ $(use_enable smartcard) \
+ --enable-ovirt=no
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}