summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-01-22 22:07:12 -0300
committerMatt Turner <mattst88@gentoo.org>2023-01-22 22:57:47 -0500
commita8c0ea2a8043ffd29c1f1573a3643c792e10c79b (patch)
tree72543cddbe522f847a68e53c5d006eda7eb8e67a /gnome-extra/gnome-commander
parentapp-office/gnumeric: Version bump to 1.12.54 (diff)
downloadgentoo-a8c0ea2a8043ffd29c1f1573a3643c792e10c79b.tar.gz
gentoo-a8c0ea2a8043ffd29c1f1573a3643c792e10c79b.tar.bz2
gentoo-a8c0ea2a8043ffd29c1f1573a3643c792e10c79b.zip
gnome-extra/gnome-commander: Version bump 1.16.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/29219 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-commander')
-rw-r--r--gnome-extra/gnome-commander/Manifest1
-rw-r--r--gnome-extra/gnome-commander/gnome-commander-1.16.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/gnome-extra/gnome-commander/Manifest b/gnome-extra/gnome-commander/Manifest
index e528b409a4ac..9acab1b74198 100644
--- a/gnome-extra/gnome-commander/Manifest
+++ b/gnome-extra/gnome-commander/Manifest
@@ -1,2 +1,3 @@
DIST gnome-commander-1.14.2.tar.xz 6868340 BLAKE2B 6b6f2a9435b9bb34a0318ddec0c509e1bef58399ce3bc1a77cf8ba6d97d5fec5e001d301e26ec7575e4c5a2f265ad0ca2e08e86f9f8045c04d6f558c17002bde SHA512 bfbc201ecaf6f9c0a71c7eba73f5d6ef9ba88f0ce8dba5d586058d87125bc51fc4b7f5e9752b7003343d686ea83db916ef78adf8c9d0df1e8715a3c88f9d1ce2
DIST gnome-commander-1.14.3.tar.xz 6862280 BLAKE2B 802a3d147c056b08025164b68d48dfc731a0db0d78ada3c5e81866e0918903d82c101fc688bb6a101760605fa17e6d45bb18800aa659b7150e376844d00d0a22 SHA512 a3a89b922c23b49587d1b459760a263c886636735549c8dcd592b1ccb838838a3748ec83eb65ca8bbb62d82d4b588479a7673314d6924075b733b31318e52756
+DIST gnome-commander-1.16.0.tar.xz 6235496 BLAKE2B a888acc48e6b402d12aec5e447c3354cf7d9a6c9138787728231f4dca837cc7fa57f7dd0b678618e63ce90ba405441e819bafe4d86cb7feee0ed2f7bf09bf212 SHA512 9e23afb9b58e1f24e8a67f81fcf9c9bbae02c07d184cf9ffd4bc56d1e4b705ea355b95ce16209d50b743898cdb7bf0b6b8730eaa44f09001d9fa9a834fcbccae
diff --git a/gnome-extra/gnome-commander/gnome-commander-1.16.0.ebuild b/gnome-extra/gnome-commander/gnome-commander-1.16.0.ebuild
new file mode 100644
index 000000000000..d9ff00029c93
--- /dev/null
+++ b/gnome-extra/gnome-commander/gnome-commander-1.16.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2 meson optfeature
+
+DESCRIPTION="A graphical, full featured, twin-panel file manager"
+HOMEPAGE="https://gcmd.github.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc exif gsf pdf samba taglib test +unique"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ doc? ( gnome-extra/yelp )
+ >=dev-libs/glib-2.70.0:2
+ >=x11-libs/gtk+-2.24.0:2
+ exif? ( >=media-gfx/exiv2-0.14 )
+ gsf? ( >=gnome-extra/libgsf-1.12:= )
+ pdf? ( >=app-text/poppler-0.18 )
+ samba? ( gnome-base/gvfs[samba] )
+ taglib? ( >=media-libs/taglib-1.4 )
+ unique? ( >=dev-libs/libunique-0.9.3:1 )
+"
+BDEPEND="
+ doc? ( app-text/yelp-tools )
+ dev-util/glib-utils
+ dev-util/gtk-doc-am
+ sys-devel/flex
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( >=dev-cpp/gtest-1.7.0 )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature exif exiv2)
+ $(meson_feature gsf libgsf)
+ $(meson_feature pdf poppler)
+ $(meson_feature samba)
+ $(meson_feature taglib)
+ $(meson_feature unique)
+ $(meson_feature test tests)
+ $(meson_use doc help)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ optfeature "synchronizing files and directories" dev-util/meld
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}