summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-12-18 22:46:59 -0500
committerMatt Turner <mattst88@gentoo.org>2021-12-18 23:53:04 -0500
commit1f6ec1776d99f9f4a75dcf888314423c2bc77ba9 (patch)
tree7d5ab1a5da1ae48a20e52d0c8b8c2f3b2d00fc2d /gnome-extra
parentgnome-extra/gnome-weather: Version bump to 41.0 (diff)
downloadgentoo-1f6ec1776d99f9f4a75dcf888314423c2bc77ba9.tar.gz
gentoo-1f6ec1776d99f9f4a75dcf888314423c2bc77ba9.tar.bz2
gentoo-1f6ec1776d99f9f4a75dcf888314423c2bc77ba9.zip
gnome-extra/gnome-user-docs: Version bump to 41.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-user-docs/Manifest1
-rw-r--r--gnome-extra/gnome-user-docs/gnome-user-docs-41.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/gnome-extra/gnome-user-docs/Manifest b/gnome-extra/gnome-user-docs/Manifest
index 8bae1a9f63cb..4fa1d3e8ee43 100644
--- a/gnome-extra/gnome-user-docs/Manifest
+++ b/gnome-extra/gnome-user-docs/Manifest
@@ -1,3 +1,4 @@
DIST gnome-user-docs-40.3.tar.xz 9141728 BLAKE2B 9634dfa526d7e781400563e0800f25fc8aa520d97fe0e02f3a06a1f82bb0019ff28e9bf0c8a2698c7d081d7b54a1d53be4475db6615d40c3407b632252cc8aae SHA512 e96f4535761c902999b210060f9bbf19384151752315abc7cf20f8b0ef1f599fe132f398db61318ea24eab8e3dc65812fc05a5ed549e4cedabaf809af39f515b
DIST gnome-user-docs-40.4.tar.xz 9195696 BLAKE2B 438f52d72a8975125b758acedfbc8c08a36397af6bb0dff01d0c73d517cee67999724e9e29d2731344fbc822309510f36f367052eeff3ba4e1dc36554eb76ffe SHA512 50c8df61a02eaa077ad3faa18d622ead97c7a8926717b2b85d6a9fb86f93e0adb3c9f212f0fbfb4781a35135fc0251d664f793665343b7daaf41a390b10fe868
DIST gnome-user-docs-40.5.tar.xz 9210512 BLAKE2B 0fe638636377d1c392d208c55016cdc346fa1ec64d327ab9ded9b58744d115c74d5a03927836138cb2d58c9df735d8bc032da4a7ff3ef3ffa53a1a59b88a3006 SHA512 dbef51c262862b211304158fd9aa7bf75ab20bbf21ed0bebe0a1c547cb53e580d32062a6f362f0750a8fbe1e93e8987593c80fa7fbb758c1a61827256db69d52
+DIST gnome-user-docs-41.1.tar.xz 9402668 BLAKE2B 952f2c117df9a9e35ae9fab13e5da402f804bce8d4fc96c07355d99e10debeb7b214f72b976826d016ae9f8d8c8a1b558d9a06f8f20e37ddd56404b6a794925a SHA512 49e08947b87ff551cfcf7de9e791de664d32f5628e1e7b4dbcf4b03e38d3e09edda602239dc52bef22a3711c437b669f8a092a33a385531e15311a0c858e78b1
diff --git a/gnome-extra/gnome-user-docs/gnome-user-docs-41.1.ebuild b/gnome-extra/gnome-user-docs/gnome-user-docs-41.1.ebuild
new file mode 100644
index 000000000000..aef106ecb64f
--- /dev/null
+++ b/gnome-extra/gnome-user-docs/gnome-user-docs-41.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2
+
+DESCRIPTION="GNOME end user documentation"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-user-docs"
+
+LICENSE="CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+BDEPEND="test? ( dev-libs/libxml2 )"
+# eautoreconf requires:
+# app-text/yelp-tools
+# rebuilding translations requires:
+# app-text/yelp-tools
+# dev-util/gettext
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip
+ !test? ( test )"
+
+src_configure() {
+ # itstool is only needed for rebuilding translations
+ # xmllint is only needed for tests
+ gnome2_src_configure \
+ $(usex test "" XMLLINT=$(type -P true)) \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ # Do not compile; "make all" with unset LINGUAS rebuilds all translations,
+ # which can take > 2 hours on a Core i7.
+ return
+}