summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-12-21 22:13:33 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-12-21 22:26:56 +0100
commit3f8da317f41a90873d5c002b19cec9e04d7ef2da (patch)
tree7777265aa2a3cd3b55378782e1ef3bb5f8869b29 /kde-apps/akonadiconsole
parentkde-apps/akonadi-search: 24.12.0-r1 version bump (diff)
downloadgentoo-3f8da317f41a90873d5c002b19cec9e04d7ef2da.tar.gz
gentoo-3f8da317f41a90873d5c002b19cec9e04d7ef2da.tar.bz2
gentoo-3f8da317f41a90873d5c002b19cec9e04d7ef2da.zip
kde-apps/akonadiconsole: 24.12.0-r1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/akonadiconsole')
-rw-r--r--kde-apps/akonadiconsole/akonadiconsole-24.12.0-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/kde-apps/akonadiconsole/akonadiconsole-24.12.0-r1.ebuild b/kde-apps/akonadiconsole/akonadiconsole-24.12.0-r1.ebuild
new file mode 100644
index 000000000000..2dca39b528fb
--- /dev/null
+++ b/kde-apps/akonadiconsole/akonadiconsole-24.12.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional" # FIXME: Check back for doc in release
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.7.0
+QTMIN=6.7.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Application for debugging Akonadi Resources"
+HOMEPAGE="https://techbase.kde.org/KDE_PIM/Akonadi/Development_Tools"
+
+LICENSE="GPL-2+ LGPL-2.1+ handbook? ( FDL-1.2+ )"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64"
+IUSE=""
+
+DEPEND="
+ dev-libs/xapian:=
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,sql,widgets]
+ >=kde-apps/akonadi-${PVCUT}:6
+ >=kde-apps/akonadi-contacts-${PVCUT}:6
+ >=kde-apps/akonadi-mime-${PVCUT}:6
+ >=kde-apps/akonadi-search-${PVCUT}:6
+ >=kde-apps/calendarsupport-${PVCUT}:6
+ >=kde-apps/kmime-${PVCUT}:6
+ >=kde-apps/libkdepim-${PVCUT}:6
+ >=kde-apps/messagelib-${PVCUT}:6
+ >=kde-frameworks/kcalendarcore-${KFMIN}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcontacts-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kcrash-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kitemmodels-${KFMIN}:6
+ >=kde-frameworks/kitemviews-${KFMIN}:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+"
+RDEPEND="${DEPEND}"