summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 10:53:06 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 14:03:48 +0200
commit44068399ad98520a66cafb092af777af8d77a11e (patch)
tree41ec18453e7fe581c9f6020280baaa81ae0a167d /kde-apps/ark
parentkde-frameworks: Add KDE Frameworks 5.50.0 (diff)
downloadgentoo-44068399ad98520a66cafb092af777af8d77a11e.tar.gz
gentoo-44068399ad98520a66cafb092af777af8d77a11e.tar.bz2
gentoo-44068399ad98520a66cafb092af777af8d77a11e.zip
kde-apps: Add KDE Applications 18.08.1
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'kde-apps/ark')
-rw-r--r--kde-apps/ark/Manifest1
-rw-r--r--kde-apps/ark/ark-18.08.1.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/kde-apps/ark/Manifest b/kde-apps/ark/Manifest
index f4b705c7db43..adf4b5f7605f 100644
--- a/kde-apps/ark/Manifest
+++ b/kde-apps/ark/Manifest
@@ -1 +1,2 @@
DIST ark-18.04.3.tar.xz 1973656 BLAKE2B afa413156233a31a1c7d102799b347b6879453a4c0a870511cb9040c9160c4da4eab30722ad9ec07ec1e9b68e942c137c464e0054738d8ee3632546b49c9dc93 SHA512 39348d3cbd3ed044ecc40a235c3e93dacb638e3ea867f814c722630786fbf7ea48643f967fb46f3358c64966a250306f11ab2a76c9147bc135ba826bcce9d33d
+DIST ark-18.08.1.tar.xz 2580104 BLAKE2B cee3333c426ebd896ed012e1cce4326cae87a5b604d712cb71d6716b485f57149d8ca06fc908e01c00f3e848d0a6f5612031127f1e53ed2fdf6d3e0d9211f516 SHA512 b4daf4f438a084df452063556a1754856a56a9a97db2c8379775d9803bc262447f7fed983c4a04e046f2a5e673ae43e4f3a902854912f79da14b9080c9970eaf
diff --git a/kde-apps/ark/ark-18.08.1.ebuild b/kde-apps/ark/ark-18.08.1.ebuild
new file mode 100644
index 000000000000..7a5bb558b1c2
--- /dev/null
+++ b/kde-apps/ark/ark-18.08.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Archiving tool"
+HOMEPAGE="https://www.kde.org/applications/utilities/ark
+https://utils.kde.org/projects/ark/"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 lzma zip"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ app-arch/libarchive:=[bzip2?,lzma?,zlib]
+ sys-libs/zlib
+ zip? ( >=dev-libs/libzip-1.2.0:= )
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtconcurrent)
+ sys-devel/gettext
+"
+
+# bug #560548, last checked with 16.04.1
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package bzip2 BZip2)
+ $(cmake-utils_use_find_package lzma LibLZMA)
+ $(cmake-utils_use_find_package zip LibZip)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version app-arch/unar && ! has_version app-arch/unrar; then
+ elog "For extracting rar archives, install app-arch/unar (free) or app-arch/unrar (non-free)."
+ fi
+
+ has_version app-arch/rar || \
+ elog "For creating rar archives, installing app-arch/rar is required."
+
+ has_version app-arch/p7zip || \
+ elog "For handling 7-Zip archives, install app-arch/p7zip."
+
+ has_version app-arch/lrzip || \
+ elog "For handling lrz archives, install app-arch/lrzip."
+}