summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-11 22:18:49 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-11 23:32:54 +0200
commitc1245e6300f7a054d1ec07c3203de104492fb18d (patch)
tree4945dc2c67198cc25ef12bc21f3b5a9e4f7c0084 /kde-apps/cantor/files
parentkde-apps/kig: python3_9 (diff)
downloadgentoo-c1245e6300f7a054d1ec07c3203de104492fb18d.tar.gz
gentoo-c1245e6300f7a054d1ec07c3203de104492fb18d.tar.bz2
gentoo-c1245e6300f7a054d1ec07c3203de104492fb18d.zip
kde-apps/cantor: python3_9 via patch to use CMake's Python3 module
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/cantor/files')
-rw-r--r--kde-apps/cantor/files/cantor-20.08.2-python.patch70
1 files changed, 70 insertions, 0 deletions
diff --git a/kde-apps/cantor/files/cantor-20.08.2-python.patch b/kde-apps/cantor/files/cantor-20.08.2-python.patch
new file mode 100644
index 000000000000..0f3c67746284
--- /dev/null
+++ b/kde-apps/cantor/files/cantor-20.08.2-python.patch
@@ -0,0 +1,70 @@
+From c09628ae8c08e8ef0e57b801994acd4276b65b02 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 11 Oct 2020 22:47:55 +0200
+Subject: [PATCH] Use CMake FindPython3 module, raises minimum CMake to 3.12
+
+---
+ CMakeLists.txt | 2 +-
+ src/backends/CMakeLists.txt | 10 ++++------
+ src/backends/python/CMakeLists.txt | 4 ++--
+ 3 files changed, 7 insertions(+), 9 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e96e6df0..a90328b5 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,4 +1,4 @@
+-cmake_minimum_required (VERSION 3.5 FATAL_ERROR)
++cmake_minimum_required (VERSION 3.12 FATAL_ERROR)
+
+ set(CMAKE_CXX_STANDARD 11)
+ set(CMAKE_CXX_STANDARD_REQUIRED ON)
+diff --git a/src/backends/CMakeLists.txt b/src/backends/CMakeLists.txt
+index e99e1731..9b6b615e 100644
+--- a/src/backends/CMakeLists.txt
++++ b/src/backends/CMakeLists.txt
+@@ -50,15 +50,13 @@ if(QALCULATE_FOUND)
+ add_subdirectory(qalculate)
+ endif(QALCULATE_FOUND)
+
+-set_package_properties(PythonLibs3 PROPERTIES DESCRIPTION "A powerful dynamic programming language."
+- URL "https://www.python.org/"
+- TYPE OPTIONAL
++set_package_properties(Python3 PROPERTIES TYPE OPTIONAL
+ PURPOSE "Backend to use Python with Cantor.")
+
+-find_package(PythonLibs3)
+-if(PYTHONLIBS3_FOUND)
++find_package(Python3 COMPONENTS Interpreter Development)
++if(Python3_FOUND)
+ add_subdirectory(python)
+-endif(PYTHONLIBS3_FOUND)
++endif()
+
+ set_package_properties(LuaJIT PROPERTIES DESCRIPTION "A lightweight, extensible programming language (luajit implementation)."
+ URL "https://www.lua.org/"
+diff --git a/src/backends/python/CMakeLists.txt b/src/backends/python/CMakeLists.txt
+index 04b4c313..ccf76193 100644
+--- a/src/backends/python/CMakeLists.txt
++++ b/src/backends/python/CMakeLists.txt
+@@ -14,7 +14,7 @@ set(PythonServer_SRCS
+ pythonserver.cpp
+ )
+
+-include_directories(${PYTHONLIBS3_INCLUDE_DIRS})
++include_directories(${Python3_INCLUDE_DIRS})
+
+ qt5_add_resources(PythonBackend_RSCS python.qrc)
+ ki18n_wrap_ui(PythonBackend_SRCS settings.ui)
+@@ -34,7 +34,7 @@ set_target_properties(cantor_pythonserver PROPERTIES INSTALL_RPATH_USE_LINK_PATH
+ if(MSVC)
+ set_property(TARGET cantor_pythonserver PROPERTY LINK_FLAGS "/SUBSYSTEM:CONSOLE")
+ endif()
+-target_link_libraries(cantor_pythonserver ${PYTHONLIBS3_LIBRARIES})
++target_link_libraries(cantor_pythonserver ${Python3_LIBRARIES})
+
+ if(BUILD_TESTING)
+ add_executable(testpython testpython.cpp settings.cpp)
+--
+2.28.0
+