summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-04-19 15:33:18 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-19 15:33:37 +0200
commit1d72a0a1cd87d7401ef850a98513c7e080d7d2e1 (patch)
treecb93e377edcbd097f32d02b97f3a1a9a5d851b10 /kde-apps/libkcddb
parentsys-kernel/gentoo-sources: Linux patch 4.16.3 (diff)
downloadgentoo-1d72a0a1cd87d7401ef850a98513c7e080d7d2e1.tar.gz
gentoo-1d72a0a1cd87d7401ef850a98513c7e080d7d2e1.tar.bz2
gentoo-1d72a0a1cd87d7401ef850a98513c7e080d7d2e1.zip
kde-apps: Add KDE Applications 18.04.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'kde-apps/libkcddb')
-rw-r--r--kde-apps/libkcddb/Manifest1
-rw-r--r--kde-apps/libkcddb/libkcddb-18.04.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/kde-apps/libkcddb/Manifest b/kde-apps/libkcddb/Manifest
index eabec75e953b..2224b990adc5 100644
--- a/kde-apps/libkcddb/Manifest
+++ b/kde-apps/libkcddb/Manifest
@@ -1 +1,2 @@
DIST libkcddb-17.12.3.tar.xz 423976 BLAKE2B a5d4723e01e53c9b168bab44b54e89d16fd5d6689da6bfb677e023ccc4478e30c1e26d682712b4313991820282628a879e4a016397ca5b84f4b53a2158870f5c SHA512 f2131996ed0727a591a3e8a265c9c65f1d1700377ccaf35e9008a2c7aee1222bb3d37d47de9f740011e9fc9c7c13936f5e473f2ccc6990e683ccce5bdd0e95f9
+DIST libkcddb-18.04.0.tar.xz 423964 BLAKE2B 8d0dc043df816a9992589aa5d9272fd79ef1d15400576da774aa2625dad8a65bb5663fd9a92a5c7cb1e96b9c78b2ab0500ece5810a7e115b46ec5cb7668ecde2 SHA512 9ec0e4ad4226ba47601f49d4eb4a076c8b9b02b3acca659a5ca9598e382160cb930fd4282d82222bca20b86375336c3e0cc45c74dabae1326109265046dd0d78
diff --git a/kde-apps/libkcddb/libkcddb-18.04.0.ebuild b/kde-apps/libkcddb/libkcddb-18.04.0.ebuild
new file mode 100644
index 000000000000..7c3b36bcccd4
--- /dev/null
+++ b/kde-apps/libkcddb/libkcddb-18.04.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_BLOCK_SLOT4="false"
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="KDE library for CDDB"
+LICENSE="GPL-2+ handbook? ( FDL-1.2 )"
+KEYWORDS="~amd64 ~x86"
+IUSE="musicbrainz"
+
+# tests require network access and compare static data with online data
+# bug 280996
+RESTRICT+=" test"
+
+DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ musicbrainz? ( media-libs/musicbrainz:5 )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ kde5_src_prepare
+
+ if ! use handbook ; then
+ pushd kcmcddb > /dev/null
+ cmake_comment_add_subdirectory doc
+ popd > /dev/null
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package musicbrainz MusicBrainz5)
+ )
+
+ kde5_src_configure
+}