summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-12-20 13:57:42 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-12-20 16:09:18 +0100
commit8fc1f020748a1a8dfcfae4693b2ee5476b9ebd19 (patch)
tree0fab7596df2c935f00b759f3b358d019a2ed0e2a /kde-frameworks/frameworkintegration
parentapp-emacs/emacs-eat: add 0.9.4 (diff)
downloadgentoo-8fc1f020748a1a8dfcfae4693b2ee5476b9ebd19.tar.gz
gentoo-8fc1f020748a1a8dfcfae4693b2ee5476b9ebd19.tar.bz2
gentoo-8fc1f020748a1a8dfcfae4693b2ee5476b9ebd19.zip
kde-frameworks/frameworkintegration: 5.247.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.247.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 7a09831b9c2b..b194056c0d8c 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,3 +1,4 @@
DIST frameworkintegration-5.112.0.tar.xz 1760464 BLAKE2B 34b68a38078faa452359921c688f4c83474c45e746badb9dd1cbdfe378268bb71b342c88761ea277c4837b5de64f0e3a417654836561385fce36eaa02ce6895e SHA512 515b6f17d6de666084b27f7d91dafbfc7e4fb704ec22a98763350976de73bbfcc215eaf0373c843ff709981b3e631f23a99c7db1bd275506bfa8d5a8649e223a
DIST frameworkintegration-5.113.0.tar.xz 1760432 BLAKE2B f8289c33889cf8bafd51b1db44efba93d9b580a9cd69be69e2fadd957a2db728d0c981da5af4c8b4be264fc3af8b7b44d6be0e144dc2a596a601cfc35f1d6274 SHA512 a9fe7a6c262482cb8b8d392064f66413a03d2bd031263470b0bbef1466bc18749d874d93c4c637958fecc72d7ec9273eabb3d48a0d7c457533c1ea7caf419e90
DIST frameworkintegration-5.246.0.tar.xz 54056 BLAKE2B 596693124b10bf10b2aad2071b2c0aa055104885bcbcd88594ee6fdaad20a39bc9fa4a8cd4999e5624e75e40f82e3b418234a2773252d6729daf0e0132bc3063 SHA512 ac465136225007948e8dae3415d447f7f9e699faf566d53625c27cc37e7823c3cde4bc08942d6ccc6fcf4943af3fb62dc7b8dcde2d9f2c393a56ab9680e82cfb
+DIST frameworkintegration-5.247.0.tar.xz 54140 BLAKE2B 92c95d1733cff1100ea27d614b2febde6d0eaa65130e409841c6705e1d9c592fdd57cf841b38224f1406860d435172597b9b0f26107d1f255d7820e4e428a9df SHA512 890d780a12a72edb359fe76cd2323eadcedfdd9485657f126bc42c29e8defdca525df90ff36fd53041d3e74d5afd5a39c2f7e306a292b022333381ed6bcff6c3
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.247.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.247.0.ebuild
new file mode 100644
index 000000000000..ff083d917e8f
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.247.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+KFMIN=5.245.0
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.6.0
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui,widgets]
+ =kde-frameworks/kcolorscheme-${PVCUT}*:6
+ =kde-frameworks/kconfig-${PVCUT}*:6
+ =kde-frameworks/ki18n-${PVCUT}*:6
+ =kde-frameworks/kiconthemes-${PVCUT}*:6
+ =kde-frameworks/knewstuff-${PVCUT}*:6
+ =kde-frameworks/knotifications-${PVCUT}*:6
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:6
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:6
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt6=ON
+ )
+
+ ecm_src_configure
+}