summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-01-14 22:59:45 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-01-14 23:27:51 +0100
commita88a066076222b3a769ad7bd9b1fd75c25301777 (patch)
tree179d1b74d2da358215026c9f1c527ee626fbce6a /kde-frameworks/frameworkintegration
parentkde-plasma/plasma-desktop: drop 5.92.0 (diff)
downloadgentoo-a88a066076222b3a769ad7bd9b1fd75c25301777.tar.gz
gentoo-a88a066076222b3a769ad7bd9b1fd75c25301777.tar.bz2
gentoo-a88a066076222b3a769ad7bd9b1fd75c25301777.zip
kde-frameworks/frameworkintegration: 5.114.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.114.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index b424a7a52509..07f487a2b142 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.113.0.tar.xz 1760432 BLAKE2B f8289c33889cf8bafd51b1db44efba93d9b580a9cd69be69e2fadd957a2db728d0c981da5af4c8b4be264fc3af8b7b44d6be0e144dc2a596a601cfc35f1d6274 SHA512 a9fe7a6c262482cb8b8d392064f66413a03d2bd031263470b0bbef1466bc18749d874d93c4c637958fecc72d7ec9273eabb3d48a0d7c457533c1ea7caf419e90
+DIST frameworkintegration-5.114.0.tar.xz 1760452 BLAKE2B 95b6ad13e185887e07ef04ba1eb696aac2d1ead3ff3b2d270044a07314b8532d5244ed23548582db852ae88b96fcbce728de6cc6fa4ccfe5467cfcc96ef1c953 SHA512 257d8b216053583c40a7586588f3ca0dff35e6240d1f222cfddc4c61c6c085a4e1ebde5a1a4bb59210db999a9fd932c3614cf8bcab6d40127413c0dc7f163e67
DIST frameworkintegration-5.248.0.tar.xz 54248 BLAKE2B 620b61128859bedc8cc2ed1aa8e0b349d93b59749ae8a2fd6f7517d9c68f6cdf3e47b7baba959a0fb30d1ae9e0c7444da9d4a9b5eabe2f4fe483fa922e258b93 SHA512 fae603dd539e522383424f72aa9deeae842ed5c6e037185d3da5292d5df6aa5c7a6694c0ed84f5cb74133918d03160cff417f525c203b7e406591b395c7eea3b
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.114.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.114.0.ebuild
new file mode 100644
index 000000000000..a35185a075f4
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.114.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}