summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-misc/kolor-manager
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-misc/kolor-manager')
-rw-r--r--kde-misc/kolor-manager/Manifest2
-rw-r--r--kde-misc/kolor-manager/files/kolor-manager-1.0.2-cmake-3.patch15
-rw-r--r--kde-misc/kolor-manager/kolor-manager-1.0.1.ebuild23
-rw-r--r--kde-misc/kolor-manager/kolor-manager-1.0.2.ebuild26
-rw-r--r--kde-misc/kolor-manager/metadata.xml5
5 files changed, 71 insertions, 0 deletions
diff --git a/kde-misc/kolor-manager/Manifest b/kde-misc/kolor-manager/Manifest
new file mode 100644
index 000000000000..496ff16c7aa4
--- /dev/null
+++ b/kde-misc/kolor-manager/Manifest
@@ -0,0 +1,2 @@
+DIST kolor-manager-1.0.1.tar.xz 48016 SHA256 e04a7655fab3b6d3459f30254e0b70113ea45526dafc0d4f72b31f6e79e28630 SHA512 204c193f214e032f2abb9d8ec89fff4901ba01543b6ede924c2ff1a5a8466b8e963afcffbd4d62eb9161844b281be00abc412401f68830a6b4fd808f3bf3aa1e WHIRLPOOL 8bbc33ee93d40dc3d5eb05c8472e6efb18e42387c2fc9bb74c99a452eb07422c0c76bb2332d8356a5b09d3c8e1ff64f162d8600c91e3314d01fda694f34a96a0
+DIST kolor-manager-1.0.2.tar.xz 49276 SHA256 2fb2e48143fa9f6ab402eb4fc2062aba412a174e7770ccf0d4359b3ce3c3024b SHA512 a0971190d2143a9471e50d4690084b7d31b8cf6bf2524f9145d858c9e3cb2a9099bf5ec6cc513c9ee82df6e554a35ed15f453f95d8c25f31e3781a21bd780556 WHIRLPOOL 0900d408682ab08a11761e9f50363d812955453c90b5eb6d8c6bf689b8ec69638bf71a93f0ce9a11084e008379a412817ef0c00a016bea7a71aa9d53870b5a94
diff --git a/kde-misc/kolor-manager/files/kolor-manager-1.0.2-cmake-3.patch b/kde-misc/kolor-manager/files/kolor-manager-1.0.2-cmake-3.patch
new file mode 100644
index 000000000000..a29b13e589eb
--- /dev/null
+++ b/kde-misc/kolor-manager/files/kolor-manager-1.0.2-cmake-3.patch
@@ -0,0 +1,15 @@
+INCLUDE is for loading CMake code, and this fails with a fatal error
+in CMake 3 as 'settings' is a directory
+
+Gentoo bug #537138
+--- information/CMakeLists.txt
++++ information/CMakeLists.txt
+@@ -3,8 +3,6 @@
+ find_package(KDE4 REQUIRED)
+ include_directories(${KDE4_INCLUDES} ${kolor_manager_SOURCE_DIR} ${CMAKE_CURRENT_BINARY_DIR})
+
+-INCLUDE( "../settings")
+-
+ set(kminfo_PART_SRCS
+ kminfo.cpp
+ )
diff --git a/kde-misc/kolor-manager/kolor-manager-1.0.1.ebuild b/kde-misc/kolor-manager/kolor-manager-1.0.1.ebuild
new file mode 100644
index 000000000000..9f483a6db06c
--- /dev/null
+++ b/kde-misc/kolor-manager/kolor-manager-1.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="KControl module for Oyranos CMS cross desktop settings"
+HOMEPAGE="http://www.oyranos.org/wiki/index.php?title=Kolor-manager"
+SRC_URI="http://dev.gentoo.org/~creffett/distfiles/${P}.tar.xz"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug"
+
+DEPEND="
+ >=media-libs/oyranos-0.9.3
+ media-libs/libXcm
+ x11-libs/libXrandr
+"
+RDEPEND="${DEPEND}"
diff --git a/kde-misc/kolor-manager/kolor-manager-1.0.2.ebuild b/kde-misc/kolor-manager/kolor-manager-1.0.2.ebuild
new file mode 100644
index 000000000000..c6524cf78f04
--- /dev/null
+++ b/kde-misc/kolor-manager/kolor-manager-1.0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="KControl module for Oyranos CMS cross desktop settings"
+HOMEPAGE="http://www.oyranos.org/wiki/index.php?title=Kolor-manager"
+SRC_URI="http://dev.gentoo.org/~johu/distfiles/${P}.tar.xz"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug"
+
+DEPEND="
+ >=media-libs/oyranos-0.9.5
+ media-libs/libXcm
+ x11-libs/libX11
+ x11-libs/libXrandr
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-cmake-3.patch" )
diff --git a/kde-misc/kolor-manager/metadata.xml b/kde-misc/kolor-manager/metadata.xml
new file mode 100644
index 000000000000..8d1e86a9cefb
--- /dev/null
+++ b/kde-misc/kolor-manager/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>