summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-10 15:22:03 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-10 19:52:32 +0100
commit049e83ff53b30814ac672dab128e71d9d0a2cfd8 (patch)
tree8ddc861ddb3d3fff31897ca2c75041349250d5c8 /kde-plasma/kscreenlocker
parentmedia-libs/mesa: Add REQUIRED_USE For USE=d3d9 (diff)
downloadgentoo-049e83ff53b30814ac672dab128e71d9d0a2cfd8.tar.gz
gentoo-049e83ff53b30814ac672dab128e71d9d0a2cfd8.tar.bz2
gentoo-049e83ff53b30814ac672dab128e71d9d0a2cfd8.zip
kde-plasma: Drop KDE Plasma 5.12.7
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'kde-plasma/kscreenlocker')
-rw-r--r--kde-plasma/kscreenlocker/Manifest1
-rw-r--r--kde-plasma/kscreenlocker/files/ck-unlock-session220
-rw-r--r--kde-plasma/kscreenlocker/kscreenlocker-5.12.7.ebuild96
-rw-r--r--kde-plasma/kscreenlocker/metadata.xml3
4 files changed, 0 insertions, 320 deletions
diff --git a/kde-plasma/kscreenlocker/Manifest b/kde-plasma/kscreenlocker/Manifest
index dcb29154832b..84176f95fae2 100644
--- a/kde-plasma/kscreenlocker/Manifest
+++ b/kde-plasma/kscreenlocker/Manifest
@@ -1,3 +1,2 @@
-DIST kscreenlocker-5.12.7.tar.xz 119484 BLAKE2B d8f0e60ec3c3f294d9daf109fc327d895f32e0c9b26841787a1ed20b5b6d3ba8113b30858caec0e8782b56d717d91979f13187466c174f4c2153678e14e7d7f3 SHA512 76554e8ad6872705e903bda5f55f650d859b282b400ca739f346e392ce7961891057c8a8a43b5dcb85c83860e4744252500c338e5d99fd67a33df529a7e040c6
DIST kscreenlocker-5.13.5.tar.xz 122112 BLAKE2B 4effbfd26b15ca9a0225031b11b892092351a95eddf2bad659b7a97e347db402d5f28415d6d8fb11eb3ad095faa7ad430e949d5f21abaf33da8cc8f47ba8e26e SHA512 c09f55da12893f162fcdc7559e55fa50d48bb642673de84809939e695ee93843e97a5224cfc79cb6bea6a1146ac757c45eab0bd1aa20e36206290c0155d8dfe2
DIST kscreenlocker-5.14.3.tar.xz 122280 BLAKE2B 03182f4ffa11727606221e8c0c77f610c18ced1392ac0059e743074cb80cb80b35cc0a5e82f6cc3457df493599e0223b5bb2bef134c45e780ba7ecb649496772 SHA512 186f693a931936658624274c7de77e8cb06c433355932a17a6c600c6cf349f848b90642b613c786c0585f050599a545d0e596d81968a6ec0b7188eb34a6e2a71
diff --git a/kde-plasma/kscreenlocker/files/ck-unlock-session b/kde-plasma/kscreenlocker/files/ck-unlock-session
deleted file mode 100644
index 6ce6935b0671..000000000000
--- a/kde-plasma/kscreenlocker/files/ck-unlock-session
+++ /dev/null
@@ -1,220 +0,0 @@
-#!/bin/sh
-
-# This script is to make unlocking using OpenRC/Consolekit easier when the KDE Screenlocker breaks.
-#
-# Version: 0.2
-# Date written: February 2, 2018
-# Last modification: February 17, 2018
-#
-# Copyright (C) 2018 Daniel Frey
-# Copyright (C) 2018 Lars Wendler
-#
-# This script is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License
-# as published by the Free Software Foundation; either version 2
-# of the License, or (at your option) any later version.
-#
-# This script is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-#
-# Some notes:
-# -The switch processing/argument handling is very basic.
-# -This script assumes session names start with "Session" when listing
-# sessions. This is settable via a variable.
-#
-# Possible actions:
-# -h : Show help screen
-# -l : List current consolekit sessions
-# -u : Unlock specified session (one parameter required - the session name)
-# -a : Attempt to unlock all sessions
-
-# Return code documentation
-#
-# 0: Script executed normally
-# 1: Root access is not present for script
-# 2: No arguments passed
-# 3: Multiple actions requested, can only do one at a time
-# 4: Argument passed was not recognized
-# 5: Multiple arguments passed for unlock single session, only one needed
-# 6: The argument required for unlocksession() is missing (internal error)
-
-SCRIPTNAME="$(basename $0)"
-
-# Return code constants
-readonly ERR_NORMAL_OPERATION=0
-readonly ERR_NO_ROOT=1
-readonly ERR_NO_ARGS=2
-readonly ERR_TOO_MANY_ACTIONS=3
-readonly ERR_INVALID_ARGUMENTS=4
-readonly ERR_TOO_MANY_ARGS=5
-readonly ERR_INTERNAL_ARG_MISSING=6
-
-# Action parameter constants
-readonly ACTION_NONE=0
-readonly ACTION_HELP=1
-readonly ACTION_LIST=2
-readonly ACTION_UNLOCKALL=3
-readonly ACTION_UNLOCK=4
-
-# This is what's used to look for a session via consolekit.
-# By default, assume it is prefixed with "Session".
-SESSION_SEARCH_PREFIX="Session"
-
-# Check to make sure script has root access, if not... abort now!
-if [ "$(id -u)" -ne 0 ]; then
- echo "This script must be run as root."
- exit ${ERR_NO_ROOT}
-fi
-
-showhelp() {
- cat <<EOF
-${SCRIPTNAME}: a script that helps unlock consolekit sessions
-
-Usage: ${SCRIPTNAME} [action] [parameters]
-
-Actions:
- -l : list current sessions available for unlocking
- -u : unlock session specified as a parameter
- -a : attempt to unlock all current sessions
- -h : this screen
-
-Parameters:
- The -u parameter requires a session name to unlock, use -l to
- list sessions.
-
-Example:
- To unlock a single session, use:
- ${SCRIPTNAME} -u Session1
-
-No arguments will show this screen.
-EOF
-}
-
-listsessions() {
- # Get a list of all sessions, and remove the full colon from the session name
- ALLSESSIONS=$(ck-list-sessions | grep "^${SESSION_SEARCH_PREFIX}" | awk -F : '{print $1}')
-
- echo
- echo "Sessions present on this machine, space-delineated:"
- echo
- echo ${ALLSESSIONS}
- echo
- echo
- echo "Session detail (to help locate a specific session:"
- ck-list-sessions | grep -A 2 "^${SESSION_SEARCH_PREFIX}"
-}
-
-unlocksession() {
- # This function expects one parameter set (the session to unlock).
- # Make sure the parameter exists before continuing.
- if [ -z "${1}" ]; then
- showhelp
- exit ${ERR_INTERNAL_ARG_MISSING}
- fi
-
- echo "Attempting to unlock session $1; messages from dbus are not suppressed."
-
- # Finally, request the unlock.
- dbus-send --system --print-reply --dest="org.freedesktop.ConsoleKit" /org/freedesktop/ConsoleKit/$1 org.freedesktop.ConsoleKit.Session.Unlock
-}
-
-unlockallsessions() {
- # Get a list of all sessions, and remove the full colon from the session name
- ALLSESSIONS=$(ck-list-sessions | grep "^${SESSION_SEARCH_PREFIX}" | awk -F : '{print $1}')
-
- echo "Attempting to unlock all sessions. Messages from dbus are not suppressed."
- echo
- # Loop through results, attempt to unlock all sessions.
- # Count them and report at the end.
- COUNT=0
- for i in ${ALLSESSIONS}; do
- dbus-send --system --print-reply --dest="org.freedesktop.ConsoleKit" /org/freedesktop/ConsoleKit/$i org.freedesktop.ConsoleKit.Session.Unlock
- let "COUNT+=1"
- done
-
- echo
- echo "Attempted to unlock ${COUNT} session(s)."
-}
-
-check_actions() {
- # Make sure multiple actions are not chosen.
- if [ ${ACTION} -ne ${ACTION_NONE} ]; then
- echo "You can only declare one action at a time!"
- echo ""
- showhelp
- exit ${ERR_TOO_MANY_ACTIONS}
- fi
-}
-
-# Start of "main" routine
-
-# Initialize variables:
-# ACTION=default 0; used to make sure more than one action are not
-# specified at the same time. If an invalid argument was passed
-# (e.g. one without the hyphen prefix) it will be caught as well.
-ACTION="${ACTION_NONE}"
-
-# Show help if no arguments provided at all
-if [ $# -eq 0 ]; then
- showhelp
- exit ${ERR_NO_ARGS}
-fi
-
-# Process arguments passed, setting environment appropriately.
-# During this check, ensure only one action was requested. This
-# script will not do multiple things at a time.
-while getopts “hlau:” OPTION; do
- case ${OPTION} in
- h) # Help action
- check_actions
- ACTION=${ACTION_HELP}
- ;;
- l) # List action
- check_actions
- ACTION="${ACTION_LIST}"
- ;;
- a) # Enable all USB hubs/devices action
- check_actions
- ACTION="${ACTION_UNLOCKALL}"
- ;;
- u) # Enable specific hub/device via find command action
- check_actions
- ACTION="${ACTION_UNLOCK}"
-
- # Save session name passed for later
- UNLOCKSESSION="${OPTARG}"
- ;;
- ?) # Unknown parameter
- showhelp
- exit ${ERR_INVALID_ARGUMENTS}
- ;;
- esac
-done
-
-# If script reaches this point, only one action was specified, so it is safe
-# to continue processing.
-case ${ACTION} in
- ${ACTION_HELP}) # help action
- showhelp
- ;;
- ${ACTION_LIST}) # list action
- listsessions
- ;;
- ${ACTION_UNLOCKALL}) # unlock all sessions
- unlockallsessions
- ;;
- ${ACTION_UNLOCK}) # unlock single session
- unlocksession ${UNLOCKSESSION}
- ;;
- *)
- echo "Unrecognized action."
- echo
- showhelp
- exit ${ERR_INVALID_ARGUMENTS}
- ;;
-esac
-
-exit ${ERR_NORMAL_OPERATION}
diff --git a/kde-plasma/kscreenlocker/kscreenlocker-5.12.7.ebuild b/kde-plasma/kscreenlocker/kscreenlocker-5.12.7.ebuild
deleted file mode 100644
index 0a3a29621480..000000000000
--- a/kde-plasma/kscreenlocker/kscreenlocker-5.12.7.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-KDE_TEST="forceoptional"
-VIRTUALX_REQUIRED="test"
-inherit kde5 pam
-
-DESCRIPTION="Library and components for secure lock screen architecture"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="consolekit +pam seccomp"
-
-REQUIRED_USE="seccomp? ( pam )"
-
-COMMON_DEPEND="
- $(add_frameworks_dep kcmutils)
- $(add_frameworks_dep kconfig)
- $(add_frameworks_dep kconfigwidgets)
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep kcrash)
- $(add_frameworks_dep kdeclarative)
- $(add_frameworks_dep kglobalaccel)
- $(add_frameworks_dep ki18n)
- $(add_frameworks_dep kidletime)
- $(add_frameworks_dep knotifications)
- $(add_frameworks_dep kpackage)
- $(add_frameworks_dep ktextwidgets)
- $(add_frameworks_dep kwayland)
- $(add_frameworks_dep kwindowsystem)
- $(add_frameworks_dep kxmlgui)
- $(add_frameworks_dep solid)
- $(add_qt_dep qtdbus)
- $(add_qt_dep qtdeclarative 'widgets')
- $(add_qt_dep qtgui)
- $(add_qt_dep qtnetwork)
- $(add_qt_dep qtwidgets)
- $(add_qt_dep qtx11extras)
- dev-libs/wayland
- x11-libs/libX11
- x11-libs/libXi
- x11-libs/libxcb
- x11-libs/xcb-util-keysyms
- pam? ( virtual/pam )
- seccomp? ( sys-libs/libseccomp )
-"
-DEPEND="${COMMON_DEPEND}
- x11-base/xorg-proto
-"
-RDEPEND="${COMMON_DEPEND}
- $(add_plasma_dep kde-cli-tools)
- !<kde-plasma/kcheckpass-4.11.22-r1:4
- !kde-plasma/kdebase-pam:0
-"
-
-RESTRICT+=" test"
-
-src_prepare() {
- kde5_src_prepare
-
- use consolekit && eapply "${FILESDIR}"/${PN}-consolekit-unlock.patch
-
- use test || sed -i \
- -e "/add_subdirectory(autotests)/ s/^/#/" greeter/CMakeLists.txt || die
-}
-
-src_test() {
- # requires running environment
- local myctestargs=(
- -E x11LockerTest
- )
- kde5_src_test
-}
-
-src_configure() {
- local mycmakeargs=(
- -DPAM_REQUIRED=$(usex pam)
- $(cmake-utils_use_find_package pam PAM)
- $(cmake-utils_use_find_package seccomp Seccomp)
- )
- kde5_src_configure
-}
-
-src_install() {
- kde5_src_install
-
- use pam && newpamd "${FILESDIR}/kde.pam" kde
- use pam && newpamd "${FILESDIR}/kde-np.pam" kde-np
-
- use consolekit && dobin "${FILESDIR}"/ck-unlock-session
-
- if ! use pam; then
- chown root "${ED}"usr/$(get_libdir)/libexec/kcheckpass || die
- chmod +s "${ED}"usr/$(get_libdir)/libexec/kcheckpass || die
- fi
-}
diff --git a/kde-plasma/kscreenlocker/metadata.xml b/kde-plasma/kscreenlocker/metadata.xml
index 099a76f8dd86..2fdbf33d963d 100644
--- a/kde-plasma/kscreenlocker/metadata.xml
+++ b/kde-plasma/kscreenlocker/metadata.xml
@@ -5,7 +5,4 @@
<email>kde@gentoo.org</email>
<name>Gentoo KDE Project</name>
</maintainer>
- <use>
- <flag name="consolekit">Add support for killing the screenlocker when <pkg>sys-auth/consolekit</pkg> is the session tracker</flag>
- </use>
</pkgmetadata>