summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-02-28 20:15:21 +0100
committerJohannes Huber <johu@gentoo.org>2017-02-28 20:29:39 +0100
commit1eca026126140e6505a9523dcb168c3d1fde6efe (patch)
tree2f1bd1e68d43d051717e00066c0c0706ae4cad7d /kde-plasma/oxygen/oxygen-5.9.2.ebuild
parentkde-plasma: Version bump KDE Plasma 5.9.3 (diff)
downloadgentoo-1eca026126140e6505a9523dcb168c3d1fde6efe.tar.gz
gentoo-1eca026126140e6505a9523dcb168c3d1fde6efe.tar.bz2
gentoo-1eca026126140e6505a9523dcb168c3d1fde6efe.zip
kde-plasma: Remove KDE Plasma 5.9.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-plasma/oxygen/oxygen-5.9.2.ebuild')
-rw-r--r--kde-plasma/oxygen/oxygen-5.9.2.ebuild85
1 files changed, 0 insertions, 85 deletions
diff --git a/kde-plasma/oxygen/oxygen-5.9.2.ebuild b/kde-plasma/oxygen/oxygen-5.9.2.ebuild
deleted file mode 100644
index 90e9e7c1a3c3..000000000000
--- a/kde-plasma/oxygen/oxygen-5.9.2.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-inherit kde5 multibuild
-
-DESCRIPTION="Oxygen visual style for the Plasma desktop"
-HOMEPAGE="https://projects.kde.org/projects/kde/workspace/oxygen"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="qt4 wayland"
-
-COMMON_DEPEND="
- $(add_frameworks_dep frameworkintegration)
- $(add_frameworks_dep kcmutils)
- $(add_frameworks_dep kcompletion)
- $(add_frameworks_dep kconfig)
- $(add_frameworks_dep kconfigwidgets)
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep kguiaddons)
- $(add_frameworks_dep ki18n)
- $(add_frameworks_dep kwidgetsaddons)
- $(add_frameworks_dep kwindowsystem)
- $(add_plasma_dep kdecoration)
- $(add_qt_dep qtdbus)
- $(add_qt_dep qtdeclarative)
- $(add_qt_dep qtgui)
- $(add_qt_dep qtwidgets)
- $(add_qt_dep qtx11extras)
- x11-libs/libxcb
- qt4? (
- kde-frameworks/kdelibs:4
- x11-libs/libX11
- )
- wayland? ( $(add_frameworks_dep kwayland) )
-"
-DEPEND="${COMMON_DEPEND}
- $(add_frameworks_dep kservice)
- qt4? (
- dev-util/automoc:0
- virtual/pkgconfig
- )
-"
-RDEPEND="${COMMON_DEPEND}
- $(add_plasma_dep kde-cli-tools)
- qt4? (
- !kde-plasma/kstyles:4
- !kde-plasma/liboxygenstyle:4
- )
- !kde-plasma/kdebase-cursors:4
-"
-
-pkg_setup() {
- kde5_pkg_setup
- MULTIBUILD_VARIANTS=( kf5 $(usev qt4) )
-}
-
-src_configure() {
- myconfigure() {
- local mycmakeargs=(
- $(cmake-utils_use_find_package wayland KF5Wayland)
- )
-
- if [[ ${MULTIBUILD_VARIANT} = qt4 ]] ; then
- mycmakeargs+=( -DUSE_KDE4=true )
- fi
-
- kde5_src_configure
- }
-
- multibuild_foreach_variant myconfigure
-}
-
-src_compile() {
- multibuild_foreach_variant kde5_src_compile
-}
-
-src_test() {
- multibuild_foreach_variant kde5_src_test
-}
-
-src_install() {
- multibuild_foreach_variant kde5_src_install
-}