summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-30 14:35:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-30 16:32:29 +0200
commit3a88c6f1b382ab5ebfe61539039a694c0e123991 (patch)
tree08f3cf35bc863ba6278e2950b9c5e72e83efe7be /kde-plasma/plasma-nm
parentacct-group/kvm: make virtualization the primary maintainer (diff)
downloadgentoo-3a88c6f1b382ab5ebfe61539039a694c0e123991.tar.gz
gentoo-3a88c6f1b382ab5ebfe61539039a694c0e123991.tar.bz2
gentoo-3a88c6f1b382ab5ebfe61539039a694c0e123991.zip
kde-plasma: Add KDE Plasma 5.16.4
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-nm')
-rw-r--r--kde-plasma/plasma-nm/Manifest1
-rw-r--r--kde-plasma/plasma-nm/plasma-nm-5.16.4.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/kde-plasma/plasma-nm/Manifest b/kde-plasma/plasma-nm/Manifest
index a37c473f7f50..84d4936a1395 100644
--- a/kde-plasma/plasma-nm/Manifest
+++ b/kde-plasma/plasma-nm/Manifest
@@ -1,2 +1,3 @@
DIST plasma-nm-5.15.5.tar.xz 777140 BLAKE2B d75ad6c04587f5bc115268f2bef50e0f6dd2b8b86957ab1f43e284988039fb7d9530cb03d86f5c49bdf6747bbb6ad123c7bc527643fe7461ed91efc93c63e563 SHA512 f3f78f40b754de5afbd63c5713e684fe3d37ae25af5a9e6ba808647e0d7d4f23456ed4b94aa8138e1fab99e7f7d7e0dffb697e0e46c99bd312bad5e2a7b9833f
DIST plasma-nm-5.16.3.tar.xz 785208 BLAKE2B 0b1ec5312ee42a5b01400c72648ab298447545856a602bfdcde9776e38f6c900e43db3511cc838e0dbc2858be031e890bc549228f389527157d645fac1bc6701 SHA512 ad48ce3e2aac9900b7c14890379e53b6b6543bbca4fcf5de1af7e7fafa86572fdefca0b938537aa1e1d5c84685d8bcbeeb6de07e30010630d811c251cdd015da
+DIST plasma-nm-5.16.4.tar.xz 788152 BLAKE2B 4bcc58f365ebf428d80c85783e11e23916efcef697902daf966f7a959824e542333ff87c3e475eb76ef6cf61de6272629031267b25676d2a68411f0584f95d48 SHA512 ebc6864e533179bf8cb85d8010c85c4180d93954a1d97072c550db391167068c78e29e7529b3d1f323fd1131d8a375cf2bf542c02a7c2a2098d827e311ce4e9d
diff --git a/kde-plasma/plasma-nm/plasma-nm-5.16.4.ebuild b/kde-plasma/plasma-nm/plasma-nm-5.16.4.ebuild
new file mode 100644
index 000000000000..995f4b6b6b89
--- /dev/null
+++ b/kde-plasma/plasma-nm/plasma-nm-5.16.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="KDE Plasma applet for NetworkManager"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="modemmanager openconnect teamd"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep networkmanager-qt 'teamd=')
+ $(add_frameworks_dep plasma)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ >=app-crypt/qca-2.1.1:2[qt5(+)]
+ net-misc/networkmanager[teamd=]
+ modemmanager? (
+ $(add_frameworks_dep modemmanager-qt)
+ $(add_qt_dep qtxml)
+ net-misc/mobile-broadband-provider-info
+ )
+ openconnect? (
+ $(add_qt_dep qtxml)
+ net-vpn/networkmanager-openconnect
+ net-vpn/openconnect:=
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_MODEMMANAGER_SUPPORT=$(usex !modemmanager)
+ $(cmake-utils_use_find_package modemmanager KF5ModemManagerQt)
+ $(cmake-utils_use_find_package openconnect OpenConnect)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-plasma/plasma-workspace:5"; then
+ elog "${PN} is not terribly useful without kde-plasma/plasma-workspace:5."
+ elog "However, the networkmanagement KCM can be called from either systemsettings"
+ elog "or manually: $ kcmshell5 kcm_networkmanagement"
+ fi
+}