summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-11-29 10:37:12 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-11-29 10:42:55 +0100
commit58c79ada9b4fed3de90aa55856ca7d3293891a4b (patch)
tree3a0d208f348d7e715d57a93060dcd42891d5c8e0 /media-gfx/exiv2
parentmedia-sound/schismtracker: removed unneeded eautoreconf (diff)
downloadgentoo-58c79ada9b4fed3de90aa55856ca7d3293891a4b.tar.gz
gentoo-58c79ada9b4fed3de90aa55856ca7d3293891a4b.tar.bz2
gentoo-58c79ada9b4fed3de90aa55856ca7d3293891a4b.zip
media-gfx/exiv2: Cleanup vulnerable 0.28.0
Bug: https://bugs.gentoo.org/917650 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/exiv2')
-rw-r--r--media-gfx/exiv2/Manifest1
-rw-r--r--media-gfx/exiv2/exiv2-0.28.0.ebuild129
2 files changed, 0 insertions, 130 deletions
diff --git a/media-gfx/exiv2/Manifest b/media-gfx/exiv2/Manifest
index fd7752e674d8..1f7d36da6fde 100644
--- a/media-gfx/exiv2/Manifest
+++ b/media-gfx/exiv2/Manifest
@@ -1,3 +1,2 @@
DIST exiv2-0.27.7-Source.tar.gz 32290404 BLAKE2B ac83c36dd15c7f6aa2d6607542a12b981d1b58bed671047d3dbfdc9eea64a977630863e4c4abe1e9c2e3e8af05adf6849a05d70e42cde4bb0d6f4a3fbb9b2e49 SHA512 8f12b056439867a05b6dfe4b93a82e02d9e5032554b590e399bcf38d73208a783f8349e66870cc030ad2a47650389d96522b60086b308145121646c9fa93d8ae
-DIST exiv2-0.28.0.tar.gz 45138274 BLAKE2B 6ccdc4e6a7dbd4aa2a892e61306f0c63659d804075cae9e771096cfdc21ec0aff0df22232c036551f4e321f497184e7ad100fb9c2011c14cd0315e8118c3e85f SHA512 35e483c6123f099167ed8647fae7c6e5512434c24d0afe684180ba6a5114068d5678280a01c8e6cfee0d1e555e1dc2a1606989d46950ce3ef1a3859caeed4dad
DIST exiv2-0.28.1.tar.gz 45225200 BLAKE2B a26f8e54cf6284c56ff429c13d5a8985dc6181a36b4c13ea6f2e59bc00016a2a8d915ddbc0cedb441b8283e30f18312a500900ffd89ca984006ac84807a03852 SHA512 7b872a3c0cbe343014b1ca4618cecaf6ee8d78dec7ef83accfce95cb8eadc6b52116977a41e1f1be5c6149a47bdd9457fadc08d73708aa2a6ab69795fd3de23b
diff --git a/media-gfx/exiv2/exiv2-0.28.0.ebuild b/media-gfx/exiv2/exiv2-0.28.0.ebuild
deleted file mode 100644
index 94eb6f257b1b..000000000000
--- a/media-gfx/exiv2/exiv2-0.28.0.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-inherit cmake-multilib python-any-r1
-
-DESCRIPTION="EXIF, IPTC and XMP metadata C++ library and command line utility"
-HOMEPAGE="https://exiv2.org/"
-
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/Exiv2/exiv2.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/Exiv2/exiv2/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ~ppc ppc64 ~riscv ~s390 sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
-fi
-
-LICENSE="GPL-2"
-# Upstream hope to have stable ABI in 1.0. Until then, go off ${PV}.
-# We may be able to change it to $(ver_cut 1-2) once e.g.
-# https://github.com/Exiv2/exiv2/pull/917 is merged.
-SLOT="0/$(ver_cut 1-2)"
-IUSE="+bmff doc examples nls +png test webready +xmp"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
- nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )
- png? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
- webready? (
- net-misc/curl[${MULTILIB_USEDEP}]
- )
- xmp? ( dev-libs/expat[${MULTILIB_USEDEP}] )
-"
-DEPEND="
- ${DEPEND}
- test? ( dev-cpp/gtest )
-"
-BDEPEND="
- doc? (
- ${PYTHON_DEPS}
- app-doc/doxygen
- dev-libs/libxslt
- media-gfx/graphviz
- virtual/pkgconfig
- )
- test? ( ${PYTHON_DEPS} )
- nls? ( sys-devel/gettext )
-"
-
-DOCS=( README.md doc/ChangeLog doc/cmd.txt )
-
-pkg_setup() {
- if use doc || use test ; then
- python-any-r1_pkg_setup
- fi
-}
-
-src_prepare() {
- # FIXME @upstream:
- einfo "Converting doc/cmd.txt to UTF-8"
- iconv -f LATIN1 -t UTF-8 doc/cmd.txt > doc/cmd.txt.tmp || die
- mv -f doc/cmd.txt.tmp doc/cmd.txt || die
-
- cmake_src_prepare
-
- sed -e "/^include.*compilerFlags/s/^/#DONT /" -i CMakeLists.txt || die
-}
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DEXIV2_BUILD_SAMPLES=NO
- -DEXIV2_ENABLE_BROTLI=OFF
- -DEXIV2_ENABLE_NLS=$(usex nls)
- -DEXIV2_ENABLE_PNG=$(usex png)
- -DEXIV2_ENABLE_CURL=$(usex webready)
- -DEXIV2_ENABLE_INIH=OFF # multilib/libdir logic is broken
- -DEXIV2_ENABLE_WEBREADY=$(usex webready)
- -DEXIV2_ENABLE_XMP=$(usex xmp)
- -DEXIV2_ENABLE_BMFF=$(usex bmff)
-
- # We let users control this.
- -DBUILD_WITH_CCACHE=OFF
- # Our toolchain sets this by default.
- -DBUILD_WITH_STACK_PROTECTOR=OFF
-
- $(multilib_is_native_abi || echo -DEXIV2_BUILD_EXIV2_COMMAND=NO)
- $(multilib_is_native_abi && echo -DEXIV2_BUILD_DOC=$(usex doc))
- $(multilib_is_native_abi && echo -DEXIV2_BUILD_UNIT_TESTS=$(usex test))
- -DCMAKE_INSTALL_DOCDIR="${EPREFIX}"/usr/share/doc/${PF}/html
- )
-
- if use doc || use test ; then
- mycmakeargs+=(
- -DPython3_EXECUTABLE="${PYTHON}"
- )
- fi
-
- cmake_src_configure
-}
-
-multilib_src_compile() {
- cmake_src_compile
-
- if multilib_is_native_abi; then
- use doc && eninja doc
- fi
-}
-
-multilib_src_test() {
- if multilib_is_native_abi; then
- cd "${BUILD_DIR}"/bin || die
- ./unit_tests || die "Failed to run tests"
- fi
-}
-
-multilib_src_install_all() {
- use xmp && DOCS+=( doc/{COPYING-XMPSDK,README-XMP,cmdxmp.txt} )
-
- einstalldocs
- find "${D}" -name '*.la' -delete || die
-
- if use examples; then
- docinto examples
- dodoc samples/*.cpp
- fi
-}