summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-07-02 13:27:49 +0200
committerJeroen Roovers <jer@gentoo.org>2016-07-02 13:27:49 +0200
commit822eb3ec491e77960fa27f4495bc19677817b11c (patch)
treed06399e5056892cf8bdf377d27eac0a057b37b90 /media-gfx/wings/wings-2.0.4-r4.ebuild
parentmedia-gfx/wings: Fix include_lib (bug #585654) in 1.5.4. (diff)
downloadgentoo-822eb3ec491e77960fa27f4495bc19677817b11c.tar.gz
gentoo-822eb3ec491e77960fa27f4495bc19677817b11c.tar.bz2
gentoo-822eb3ec491e77960fa27f4495bc19677817b11c.zip
media-gfx/wings: Use sh instead of bash.
Package-Manager: portage-2.3.0
Diffstat (limited to 'media-gfx/wings/wings-2.0.4-r4.ebuild')
-rw-r--r--media-gfx/wings/wings-2.0.4-r4.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/media-gfx/wings/wings-2.0.4-r4.ebuild b/media-gfx/wings/wings-2.0.4-r4.ebuild
new file mode 100644
index 000000000000..9b046f2ba1fb
--- /dev/null
+++ b/media-gfx/wings/wings-2.0.4-r4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils multilib
+
+DESCRIPTION="Wings 3D is an advanced subdivision modeler"
+HOMEPAGE="http://www.wings3d.com/"
+SRC_URI="mirror://sourceforge/wings/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-lang/erlang-18.1[smp,wxwidgets]
+ dev-libs/cl
+ media-libs/libsdl[opengl]
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e '/include_lib/s|"wings/|"../|' \
+ $(find . -name '*'.erl) \
+ || die
+
+ eapply_user
+}
+
+src_configure() {
+ export ERL_PATH="/usr/$(get_libdir)/erlang/lib/"
+}
+
+src_compile() {
+ # Work around parallel make issues
+ emake vsn.mk
+ for subdir in intl_tools src e3d icons plugins_src; do
+ emake -C ${subdir}
+ done
+}
+
+src_install() {
+ WINGS_PATH=${ERL_PATH}/${P}
+ dodir ${WINGS_PATH}
+
+ find -name 'Makefile*' -exec rm -f '{}' \;
+
+ insinto ${WINGS_PATH}
+ doins -r e3d ebin icons plugins psd shaders src textures tools
+
+ newbin "${FILESDIR}"/wings.sh-r1 wings
+ dodoc AUTHORS README
+}