summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-02-01 18:40:16 -0500
committerMatt Turner <mattst88@gentoo.org>2024-02-01 18:42:57 -0500
commite3473afeac9dbe9e820f658c783c46416ee30d8c (patch)
treee4b5f9b364add9ca60d86e599d6dffb60a3e6b3e /media-libs/mesa
parentdev-python/pyside2: drop 5.15.11-r1 (diff)
downloadgentoo-e3473afeac9dbe9e820f658c783c46416ee30d8c.tar.gz
gentoo-e3473afeac9dbe9e820f658c783c46416ee30d8c.tar.bz2
gentoo-e3473afeac9dbe9e820f658c783c46416ee30d8c.zip
media-libs/mesa: Revert "Add VIDEO_CARDS=swrast"
This reverts commit 46b2f0ab301a02e8763e461140b317e6dcd707bc. Users of the proprietary NVIDIA driver will likely have media-libs/mesa installed with no VIDEO_CARDS set, and without a driver present the configuration step fails. Bug: https://bugs.gentoo.org/920752 Closes: https://bugs.gentoo.org/923494 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/mesa-24.0.0.ebuild9
-rw-r--r--media-libs/mesa/mesa-9999.ebuild9
2 files changed, 8 insertions, 10 deletions
diff --git a/media-libs/mesa/mesa-24.0.0.ebuild b/media-libs/mesa/mesa-24.0.0.ebuild
index 28a5b5573daa..7d7f3b5ed165 100644
--- a/media-libs/mesa/mesa-24.0.0.ebuild
+++ b/media-libs/mesa/mesa-24.0.0.ebuild
@@ -25,7 +25,7 @@ SLOT="0"
RESTRICT="!test? ( test )"
RADEON_CARDS="r300 r600 radeon radeonsi"
-VIDEO_CARDS="${RADEON_CARDS} d3d12 freedreno intel swrast lima nouveau panfrost v3d vc4 virgl vivante vmware"
+VIDEO_CARDS="${RADEON_CARDS} d3d12 freedreno intel lavapipe lima nouveau panfrost v3d vc4 virgl vivante vmware"
for card in ${VIDEO_CARDS}; do
IUSE_VIDEO_CARDS+=" video_cards_${card}"
done
@@ -47,9 +47,8 @@ REQUIRED_USE="
video_cards_vmware
)
)
- osmesa? ( video_cards_swrast )
vulkan-overlay? ( vulkan )
- video_cards_swrast? ( vulkan? ( llvm ) )
+ video_cards_lavapipe? ( llvm vulkan )
video_cards_radeon? ( x86? ( llvm ) amd64? ( llvm ) )
video_cards_r300? ( x86? ( llvm ) amd64? ( llvm ) )
vdpau? ( X )
@@ -341,7 +340,7 @@ multilib_src_configure() {
gallium_enable -- kmsro
fi
- gallium_enable video_cards_swrast swrast
+ gallium_enable -- swrast
gallium_enable video_cards_freedreno freedreno
gallium_enable video_cards_intel crocus i915 iris
gallium_enable video_cards_lima lima
@@ -373,7 +372,7 @@ multilib_src_configure() {
fi
if use vulkan; then
- vulkan_enable video_cards_swrast swrast
+ vulkan_enable video_cards_lavapipe swrast
vulkan_enable video_cards_freedreno freedreno
vulkan_enable video_cards_intel intel intel_hasvk
vulkan_enable video_cards_d3d12 microsoft-experimental
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 28a5b5573daa..7d7f3b5ed165 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -25,7 +25,7 @@ SLOT="0"
RESTRICT="!test? ( test )"
RADEON_CARDS="r300 r600 radeon radeonsi"
-VIDEO_CARDS="${RADEON_CARDS} d3d12 freedreno intel swrast lima nouveau panfrost v3d vc4 virgl vivante vmware"
+VIDEO_CARDS="${RADEON_CARDS} d3d12 freedreno intel lavapipe lima nouveau panfrost v3d vc4 virgl vivante vmware"
for card in ${VIDEO_CARDS}; do
IUSE_VIDEO_CARDS+=" video_cards_${card}"
done
@@ -47,9 +47,8 @@ REQUIRED_USE="
video_cards_vmware
)
)
- osmesa? ( video_cards_swrast )
vulkan-overlay? ( vulkan )
- video_cards_swrast? ( vulkan? ( llvm ) )
+ video_cards_lavapipe? ( llvm vulkan )
video_cards_radeon? ( x86? ( llvm ) amd64? ( llvm ) )
video_cards_r300? ( x86? ( llvm ) amd64? ( llvm ) )
vdpau? ( X )
@@ -341,7 +340,7 @@ multilib_src_configure() {
gallium_enable -- kmsro
fi
- gallium_enable video_cards_swrast swrast
+ gallium_enable -- swrast
gallium_enable video_cards_freedreno freedreno
gallium_enable video_cards_intel crocus i915 iris
gallium_enable video_cards_lima lima
@@ -373,7 +372,7 @@ multilib_src_configure() {
fi
if use vulkan; then
- vulkan_enable video_cards_swrast swrast
+ vulkan_enable video_cards_lavapipe swrast
vulkan_enable video_cards_freedreno freedreno
vulkan_enable video_cards_intel intel intel_hasvk
vulkan_enable video_cards_d3d12 microsoft-experimental