summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-01-10 10:04:47 +1300
committerJoonas Niilola <juippis@gentoo.org>2021-01-10 05:42:07 +0200
commite4c4ea585e1c10c364abe3421811caf4a3ad2198 (patch)
treeea9a5c781ea4d77956e4cb17b6d941cfdd0e7be1 /media-libs/svt-av1/svt-av1-9999.ebuild
parentdev-libs/apr: Fixed build with sys-devel/autoconf-2.70 (diff)
downloadgentoo-e4c4ea585e1c10c364abe3421811caf4a3ad2198.tar.gz
gentoo-e4c4ea585e1c10c364abe3421811caf4a3ad2198.tar.bz2
gentoo-e4c4ea585e1c10c364abe3421811caf4a3ad2198.zip
media-libs/svt-av1: new package 0.8.6
The Scalable Video Technology for AV1 (SVT-AV1 Encoder and Decoder) is an AV1-compliant encoder/decoder library core. The SVT-AV1 encoder development is a work-in-progress targeting performance levels applicable to both VOD and Live encoding / transcoding video applications. The SVT-AV1 decoder implementation is targeting future codec research activities. Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de> Closes: https://github.com/gentoo/gentoo/pull/17110 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs/svt-av1/svt-av1-9999.ebuild')
-rw-r--r--media-libs/svt-av1/svt-av1-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/svt-av1/svt-av1-9999.ebuild b/media-libs/svt-av1/svt-av1-9999.ebuild
new file mode 100644
index 000000000000..9bd9658e06a6
--- /dev/null
+++ b/media-libs/svt-av1/svt-av1-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Scalable Video Technology for AV1 (SVT-AV1 Encoder and Decoder)"
+HOMEPAGE="https://github.com/AOMediaCodec/SVT-AV1"
+
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/AOMediaCodec/SVT-AV1.git"
+else
+ SRC_URI="https://github.com/AOMediaCodec/SVT-AV1/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 -x86" # -x86: https://github.com/AOMediaCodec/SVT-AV1/issues/1231
+ S="${WORKDIR}/SVT-AV1-${PV}"
+fi
+
+# Also see "Alliance for Open Media Patent License 1.0"
+LICENSE="BSD-2 Apache-2.0 BSD ISC LGPL-2.1+ MIT"
+SLOT="0"
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ local mycmakeargs=(
+ # Tests require linking against https://github.com/Cidana-Developers/aom/tree/av1-normative ?
+ # undefined reference to `ifd_inspect'
+ # https://github.com/Cidana-Developers/aom/commit/cfc5c9e95bcb48a5a41ca7908b44df34ea1313c0
+ -DBUILD_TESTING=OFF
+ )
+
+ cmake_src_configure
+}