summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-02-19 19:17:20 +0100
committerDavid Seifert <soap@gentoo.org>2018-02-19 20:40:26 +0100
commit4655cbda0d84d7bb645611d14839607140f1acac (patch)
tree5cd560f868b16502c4dd95b55e70481cda147e69 /media-libs
parentmedia-libs/harfbuzz: Always build in C++14 mode (diff)
downloadgentoo-4655cbda0d84d7bb645611d14839607140f1acac.tar.gz
gentoo-4655cbda0d84d7bb645611d14839607140f1acac.tar.bz2
gentoo-4655cbda0d84d7bb645611d14839607140f1acac.zip
media-libs/libcdr: Always build in C++14 mode
Closes: https://bugs.gentoo.org/619448 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libcdr/libcdr-0.1.4.ebuild7
-rw-r--r--media-libs/libcdr/libcdr-9999.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/media-libs/libcdr/libcdr-0.1.4.ebuild b/media-libs/libcdr/libcdr-0.1.4.ebuild
index b114fa2e952e..2e4ecae4b778 100644
--- a/media-libs/libcdr/libcdr-0.1.4.ebuild
+++ b/media-libs/libcdr/libcdr-0.1.4.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit flag-o-matic
+
EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libcdr.git"
[[ ${PV} == 9999 ]] && inherit autotools git-r3
@@ -37,6 +39,9 @@ src_prepare() {
}
src_configure() {
+ # bug 619448
+ append-cxxflags -std=c++14
+
econf \
--disable-werror \
$(use_with doc docs) \
diff --git a/media-libs/libcdr/libcdr-9999.ebuild b/media-libs/libcdr/libcdr-9999.ebuild
index a7f1ed801fda..3c04d584f9e0 100644
--- a/media-libs/libcdr/libcdr-9999.ebuild
+++ b/media-libs/libcdr/libcdr-9999.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit flag-o-matic
+
EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libcdr.git"
[[ ${PV} == 9999 ]] && inherit autotools git-r3
@@ -37,6 +39,9 @@ src_prepare() {
}
src_configure() {
+ # bug 619448
+ append-cxxflags -std=c++14
+
econf \
--disable-werror \
$(use_with doc docs) \