summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-12-24 10:15:46 +0000
committerSam James <sam@gentoo.org>2024-12-24 10:20:15 +0000
commit08095775d3048952f72a298f60e148b4e7262459 (patch)
tree266bad5facba5f79892e3b2fc2bceb2ac2a09a22 /media-plugins
parentmedia-plugins/gst-plugins-uvch264: add 1.22.12 (diff)
downloadgentoo-08095775d3048952f72a298f60e148b4e7262459.tar.gz
gentoo-08095775d3048952f72a298f60e148b4e7262459.tar.bz2
gentoo-08095775d3048952f72a298f60e148b4e7262459.zip
media-plugins/gst-plugins-vaapi: add 1.22.12
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/gst-plugins-vaapi/Manifest1
-rw-r--r--media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.22.12.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-vaapi/Manifest b/media-plugins/gst-plugins-vaapi/Manifest
index fa134e65fe57..65abdeb59d6b 100644
--- a/media-plugins/gst-plugins-vaapi/Manifest
+++ b/media-plugins/gst-plugins-vaapi/Manifest
@@ -1 +1,2 @@
DIST gstreamer-vaapi-1.22.11.tar.xz 552468 BLAKE2B 0353699651add70639a4f7d591eccb646f5d6cda3ba8832553597b7b4e9bd3ebfe07d9eb1ac6e078219ee630131d502adccc8106a2207bb0234353905bafd8cd SHA512 939b748fea88c94ad59c1d4610a872a794b383382096a8f5f011a21d4c8fb041c28e1aa9a8d54f519fb3e48a69ed79622b0d45be01d2d5a900738a7928401563
+DIST gstreamer-vaapi-1.22.12.tar.xz 556192 BLAKE2B d8a1a0cb6616f001b1bc98febcb50c61e3af222f9461e8bb9b9d7cb43fd907f115eae76e1c069108fc98370432a82d4a754135a4e755f66d0a3107f205372793 SHA512 6253a97918cf8da5d063bfb9e3e8809c43610cc6495181319e7f198f43395637664ba867b210eaa72d74138dd9be4c39e3cd2d9e6d889ce4a06b0c2ad577f47a
diff --git a/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.22.12.ebuild b/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.22.12.ebuild
new file mode 100644
index 000000000000..0b2bbaa48bca
--- /dev/null
+++ b/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.22.12.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gstreamer-meson
+
+MY_PN="gstreamer-vaapi"
+DESCRIPTION="Hardware accelerated video decoding through VA-API plugin for GStreamer"
+HOMEPAGE="https://gitlab.freedesktop.org/gstreamer/gstreamer-vaapi"
+SRC_URI="https://gstreamer.freedesktop.org/src/${MY_PN}/${MY_PN}-${PV}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="1.0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="+drm +egl +gles2 opengl wayland +X" # Keep default enabled IUSE in sync with gst-plugins-base and libva
+
+# gst-vaapi configure is based around GL platform mainly, unlike gst-plugins-bad that goes by GL API mainly; for less surprises,
+# we design gst-vaapi ebuild in terms of GL API as main choice as well, meaning that USE opengl and/or gles2 is required to
+# enable opengl support at all and choices get chained from there.
+# One or multiple video output are required: drm, x11, glx, egl and/or wayland;
+# but GL API is our main trigger, thus USE=egl should be ineffective if neither gles2 or opengl is enabled;
+# So "|| ( drm egl opengl wayland X )" would be wrong, because egl isn't built with USE="egl -opengl -gles2", ending up with no video outputs.
+# As we ensure at least one working GL output with other REQUIRED_USE, we can put gles2/opengl in REQUIRED_USE instead of egl, solving the issue.
+# gles2 API only supported windowing system (on linux) is EGL, so require it
+# opengl API only supported windowing systems (on linux) are EGL and GLX, so require one of them (glx is enabled with USE="opengl X")
+REQUIRED_USE="
+ || ( drm gles2 opengl wayland X )
+ gles2? ( egl )
+ opengl? ( || ( egl X ) )
+ wayland? ( drm )
+"
+
+# glx doesn't require libva-glx (libva[opengl]) afaics, only by tests/test-display.c
+# USE flag behavior:
+# 'drm' enables vaapi drm support
+# 'egl' enables EGL platform support (but only if also 'opengl||gles2')
+# - 'egl' is exposed as a USE flag mainly to get EGL support instead of or in addition to GLX support with desktop GL while keeping it optional for pure GLX cases;
+# it's always required with USE=gles2, thus USE="gles2 opengl X" will require and build desktop GL EGL platform support as well on top of GLX, which doesn't add extra deps at that point.
+# 'gles2' enables GLESv2 or GLESv3 based GL API support
+# 'opengl' enables desktop OpenGL based GL API support
+# 'wayland' enables non-GL Wayland support; wayland EGL support when combined with 'egl' (but only if also 'opengl||gles2')
+# 'X' enables non-GL X support; GLX support when combined with 'opengl'
+# gst-plugins-bad still needed for codecparsers (GL libraries moved to -base); checked for 1.14 (recheck for 1.16)
+GST_REQ="${PV}"
+GL_DEPS="
+ >=media-libs/gst-plugins-base-${GST_REQ}:${SLOT}[egl?,gles2?,opengl?,wayland?,X?]
+ || (
+ >=media-libs/mesa-24.1.0_rc1[opengl,X?,${MULTILIB_USEDEP}]
+ <media-libs/mesa-24.1.0_rc1[gles2?,egl(+)?,X?,${MULTILIB_USEDEP}]
+ )
+"
+RDEPEND="
+ >=media-libs/gst-plugins-base-${GST_REQ}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-bad-${GST_REQ}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/libva-1.10.0:=[drm(+)?,wayland?,X?,${MULTILIB_USEDEP}]
+ drm? (
+ >=virtual/libudev-208:=[${MULTILIB_USEDEP}]
+ >=x11-libs/libdrm-2.4.98[${MULTILIB_USEDEP}]
+ )
+ gles2? ( ${GL_DEPS} )
+ opengl? ( ${GL_DEPS} )
+ wayland? ( >=dev-libs/wayland-1.11.0[${MULTILIB_USEDEP}] )
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrandr-1.4.2[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+# FIXME: "Failed to create vaapipostproc element"
+RESTRICT="test"
+
+multilib_src_configure() {
+ GST_PLUGINS_NOAUTO="wayland"
+
+ local emesonargs=(
+ -Dencoders=enabled
+ $(meson_feature drm)
+ $(meson_feature X x11)
+ $(meson_feature wayland)
+ )
+
+ if use opengl || use gles2; then
+ emesonargs+=( $(meson_feature egl) )
+ else
+ emesonargs+=( -Degl=disabled )
+ fi
+
+ if use opengl && use X; then
+ emesonargs+=( -Dglx=enabled )
+ else
+ emesonargs+=( -Dglx=disabled )
+ fi
+
+ # Workaround EGL/eglplatform.h being built with X11 present
+ use X || export CFLAGS="${CFLAGS} -DEGL_NO_X11"
+
+ gstreamer_multilib_src_configure
+}