summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James (sam_c) <sam@cmpct.info>2020-03-25 03:22:33 +0000
committerJoonas Niilola <juippis@gentoo.org>2020-03-31 11:38:58 +0300
commit8c293c2d398dbbe110b67473cc43835a43873c8c (patch)
treea972257a0e227a7bb81c0f791e2ab3c5e1b03a92 /media-plugins
parentsys-kernel/linux-headers: Stable for HPPA (diff)
downloadgentoo-8c293c2d398dbbe110b67473cc43835a43873c8c.tar.gz
gentoo-8c293c2d398dbbe110b67473cc43835a43873c8c.tar.bz2
gentoo-8c293c2d398dbbe110b67473cc43835a43873c8c.zip
media-plugins/live: Security bump to 2020.03.06
* Decided to bump to the latest while there. * Adds an optional ssl dependency. * Bumps from EAPI 5 => 7 Bug: https://bugs.gentoo.org/669276 Signed-off-by: Sam James (sam_c) <sam@cmpct.info> Closes: https://github.com/gentoo/gentoo/pull/15100 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/live/Manifest1
-rw-r--r--media-plugins/live/files/config.gentoo-so-r317
-rw-r--r--media-plugins/live/live-2020.03.06.ebuild100
3 files changed, 118 insertions, 0 deletions
diff --git a/media-plugins/live/Manifest b/media-plugins/live/Manifest
index 17048de8013f..cf3b64892632 100644
--- a/media-plugins/live/Manifest
+++ b/media-plugins/live/Manifest
@@ -1,3 +1,4 @@
DIST live.2017.10.28.tar.gz 629858 BLAKE2B a1d862ae1356b46fcd4e5ef7e27c47d3fb3abac35add6feb7955f60ddbd93e9242a84102393de67dda0d39c09632a0cc9a5f54d30c9f91d005696d3a566258bd SHA512 eea5bdb8d89e76c8b6aeb6ec04b77af3048cb41f228d230ba4da6045e9bc691a456023d44d8650fe690b08143567ed5af5b633f5b6522debff79344a813dc7d0
DIST live.2018.01.29.tar.gz 630144 BLAKE2B dd58865636a44ccabd0e3b02e1679393f17fb09d82455188d49d4fcb321b21e136a168c0f4c407c1dba3afcb5b541192cd2c5181d7a7710d39d4727526fc39cf SHA512 dfdfcac67acd28f651807de423c6aed00190cfc38ecd361b76d37d8cc27ee2fa91a42a5b8835045680fd7f65c847e41747b948c2c71e6530a3c7e89421c60227
DIST live.2018.07.07.tar.gz 630625 BLAKE2B 8545d4d8ed60328ccc782b6c2a8c4a0dc9ce3c1245fbc78fed4d3eb6f42de39c3c341456dc00cdc416fdcb2e518f5fe387273f5b4d2c3e2d32bfa22a21df2a90 SHA512 e7d4ddf51e9666c6ebe9a46976035b68fea94be54825535ffb04006cd242b9d3ad08250305206442bed3500d1e8d628ccf44302c485f63a9e244b3f8b1e27fe4
+DIST live.2020.03.06.tar.gz 7231080 BLAKE2B 95a1d3cc394eba473296973a1e44160dd1ca8e2efbc322a2e0bfbdb183244cda28b219ea14a51c8d146807d829b566a9c3782b291d5abfbd306a92e030e108e4 SHA512 7da439fbdeab0da6687dee56d9a27bf7b8f8a9c84b420d72f2e2a7ff7a73d18756d1fdb920f29b36917d93efcecc9230877637322d5041eeba114882b4bf7a06
diff --git a/media-plugins/live/files/config.gentoo-so-r3 b/media-plugins/live/files/config.gentoo-so-r3
new file mode 100644
index 000000000000..905e9e0b59a2
--- /dev/null
+++ b/media-plugins/live/files/config.gentoo-so-r3
@@ -0,0 +1,17 @@
+COMPILE_OPTS = $(INCLUDES) -I. -DSOCKLEN_T=socklen_t -D_LARGEFILE_SOURCE=1 -D_FILE_OFFSET_BITS=64 -DXLOCALE_NOT_USED -DNO_OPENSSL=1
+C = c
+C_COMPILER = $(CC)
+C_FLAGS = $(COMPILE_OPTS) -fPIC $(CFLAGS)
+CPP = cpp
+CPLUSPLUS_COMPILER = $(CXX)
+CPLUSPLUS_FLAGS = $(COMPILE_OPTS) -fPIC $(CXXFLAGS)
+OBJ = o
+LINK = $(CXX) -o
+LINK_OPTS = -L.
+CONSOLE_LINK_OPTS = $(LINK_OPTS)
+LIBRARY_LINK = $(CXX) -o
+LIBRARY_LINK_OPTS = $(LINK_OPTS) -shared -Wl,-soname,$@
+LIB_SUFFIX = so
+LIBS_FOR_CONSOLE_APPLICATION =
+LIBS_FOR_GUI_APPLICATION =
+EXE =
diff --git a/media-plugins/live/live-2020.03.06.ebuild b/media-plugins/live/live-2020.03.06.ebuild
new file mode 100644
index 000000000000..93524cfa7228
--- /dev/null
+++ b/media-plugins/live/live-2020.03.06.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Libraries for standards-based RTP/RTCP/RTSP multimedia streaming"
+HOMEPAGE="http://www.live555.com/"
+SRC_URI="http://www.live555.com/liveMedia/public/${P/-/.}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="libressl ssl"
+DOCS=( "live-shared/README" )
+DEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+"
+
+# Alexis Ballier <aballier@gentoo.org>, Sam James <sam@cmpct.info>
+# Be careful, bump this everytime you bump the package and the ABI has changed.
+# If you don't know, ask someone.
+# You may wish to use a site like https://abi-laboratory.pro/index.php?view=timeline&l=live555
+LIVE_ABI_VERSION=8
+SLOT="0/${LIVE_ABI_VERSION}"
+
+S="${WORKDIR}/live"
+
+src_prepare() {
+ default
+
+ cp "${FILESDIR}/config.gentoo-so-r3" "${S}/config.gentoo-so-r1" || die
+
+ # This is all legacy stuff which needs to be cleaned up
+ case ${CHOST} in
+ *-solaris*)
+ sed -i \
+ -e '/^COMPILE_OPTS /s/$/ -DSOLARIS -DXLOCALE_NOT_USED/' \
+ -e '/^LIBS_FOR_CONSOLE_APPLICATION /s/$/ -lsocket -lnsl/' \
+ live/config.gentoo-so-r1 \
+ || die
+ ;;
+ *-darwin*)
+ sed -i \
+ -e '/^COMPILE_OPTS /s/$/ -DBSD=1 -DHAVE_SOCKADDR_LEN=1/' \
+ -e '/^LINK /s/$/ /' \
+ -e '/^LIBRARY_LINK /s/=.*$/= $(CXX) -o /' \
+ -e '/^LIBRARY_LINK_OPTS /s:-shared.*$:-undefined suppress -flat_namespace -dynamiclib -install_name '"${EPREFIX}/usr/$(get_libdir)/"'$@:' \
+ -e '/^LIB_SUFFIX /s/so/dylib/' \
+ live/config.gentoo-so-r1 \
+ || die shared
+ ;;
+ esac
+}
+
+src_configure() {
+ # This ebuild uses its own build system
+ # We don't want to call ./configure or anything here.
+ # The only thing we can do is honour the user's SSL preference.
+ if use ssl; then
+ sed -i 's/-DNO_OPENSSL=1//' "${S}/config.gentoo-so-r1" || die
+ fi
+
+ # And defer to the scripts that upstream provide.
+ ./genMakefiles gentoo-so-r1 || die
+}
+
+src_compile() {
+ export suffix="${LIVE_ABI_VERSION}.so"
+ local link_opts="$(usex ssl '-lssl' '') -L. ${LDFLAGS}"
+ local lib_suffix="${suffix#.}"
+
+ einfo "Beginning shared library build"
+ emake LINK_OPTS="${link_opts}" LIB_SUFFIX="${lib_suffix}"
+
+ for i in liveMedia groupsock UsageEnvironment BasicUsageEnvironment ; do
+ cd "${S}/${i}" || die
+ ln -s "lib${i}.${suffix}" "lib${i}.so" || die
+ done
+
+ einfo "Beginning programs build"
+ for i in proxyServer mediaServer ; do
+ cd "${S}/${i}" || die
+ emake LINK_OPTS="${link_opts}"
+ done
+}
+
+src_install() {
+ for library in UsageEnvironment liveMedia BasicUsageEnvironment groupsock; do
+ dolib.so "${S}/${library}/lib${library}.${suffix}"
+ dosym "lib${library}.${suffix}" "/usr/$(get_libdir)/lib${library}.so"
+
+ insinto /usr/include/"${library}"
+ doins "${S}/${library}"/include/*h
+ done
+
+ dobin ${S}/mediaServer/live555MediaServer
+ dobin ${S}/proxyServer/live555ProxyServer
+}