summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-10-09 09:58:19 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2022-10-09 09:58:26 +0200
commitf22ad96fb322fef940d4203e422f0cac93b9a836 (patch)
tree5de590c2768c8dd6b51ecac64bed4c62a3646ab7 /media-sound/terminatorx
parentdev-python/secretstorage: Align parentheses (diff)
downloadgentoo-f22ad96fb322fef940d4203e422f0cac93b9a836.tar.gz
gentoo-f22ad96fb322fef940d4203e422f0cac93b9a836.tar.bz2
gentoo-f22ad96fb322fef940d4203e422f0cac93b9a836.zip
media-sound/terminatorx: bump to 4.2.0
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/terminatorx')
-rw-r--r--media-sound/terminatorx/Manifest1
-rw-r--r--media-sound/terminatorx/files/terminatorx-4.2.0-metadata-dir.patch13
-rw-r--r--media-sound/terminatorx/terminatorx-4.2.0.ebuild66
3 files changed, 80 insertions, 0 deletions
diff --git a/media-sound/terminatorx/Manifest b/media-sound/terminatorx/Manifest
index 3c44cda476d0..292976ca1edc 100644
--- a/media-sound/terminatorx/Manifest
+++ b/media-sound/terminatorx/Manifest
@@ -1 +1,2 @@
DIST terminatorX-4.1.0.tar.bz2 1832295 BLAKE2B a328d05bb0c3c88719eb711dcf3f50eac08cd140e3225f42633744b39ce49f3e074263997ec21b2cc245740fa3f672a19b89d929fad1d0131981988fc80f37fc SHA512 2dc87bdbb4f4d24e10f0c8fac99b4ccecac6036c6dc950184cbdd1d05fe0a4c723ea1b04c49837fb0aa8f149ca9d2fb5d2c42f5109031184980a14fe549312fc
+DIST terminatorX-4.2.0.tar.bz2 1821474 BLAKE2B dc86555bdb0d837d12144b392cf6a1cdf707268a3634940bed66792432ef014d168dbee2fd540a253ad369ff4aeaf5d0b7dfb252f3c97550a2c4af5ad1a58945 SHA512 e10ac7acd91441dabad80ae7c144b56f39ebfb4c76f0e3bfab093937c69d2c6b0834a68a0a216994898ae05a7f9ae5ebac0b1fa52d65d627b7ed01785fc55941
diff --git a/media-sound/terminatorx/files/terminatorx-4.2.0-metadata-dir.patch b/media-sound/terminatorx/files/terminatorx-4.2.0-metadata-dir.patch
new file mode 100644
index 000000000000..6fe84c945d09
--- /dev/null
+++ b/media-sound/terminatorx/files/terminatorx-4.2.0-metadata-dir.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.in b/Makefile.in
+index 7c7e2ba..98f4fc8 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -367,7 +367,7 @@ EXTRA_DIST = COPYING-DOCS\
+ # Destkop Entry
+ desktopdir = $(datadir)/applications
+ desktop_DATA = terminatorX.desktop
+-appdatadir = $(datarootdir)/appdata
++appdatadir = $(datarootdir)/metadata
+ appdata_DATA = terminatorX.appdata.xml
+ mimedir = $(datadir)/mime-info
+ mime_DATA = terminatorX.mime terminatorX.keys
diff --git a/media-sound/terminatorx/terminatorx-4.2.0.ebuild b/media-sound/terminatorx/terminatorx-4.2.0.ebuild
new file mode 100644
index 000000000000..ca8785ba193d
--- /dev/null
+++ b/media-sound/terminatorx/terminatorx-4.2.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2
+
+MY_P=${P/terminatorx/terminatorX}
+
+DESCRIPTION="Realtime audio synthesizer allowing you to 'scratch' on sampled audio data"
+HOMEPAGE="https://www.terminatorx.org/"
+# this is the original location but there is an issue with their certificate so mirroring the file
+#SRC_URI="https://www.terminatorx.org/dist/${MY_P}.tar.bz2"
+SRC_URI="https://dev.gentoo.org/~fordfrog/distfiles/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# Making X optional fails when disabled: https://bugs.gentoo.org/636832
+IUSE="+alsa debug jack mad pulseaudio vorbis sox"
+
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2:2
+ media-libs/audiofile:=
+ media-libs/ladspa-sdk
+ media-libs/liblrdf
+ media-plugins/cmt-plugins
+ x11-libs/gtk+:3
+ x11-libs/libXi
+ x11-libs/libXxf86dga
+ alsa? ( media-libs/alsa-lib )
+ jack? ( virtual/jack )
+ mad? ( media-sound/madplay )
+ pulseaudio? ( media-sound/pulseaudio )
+ vorbis? ( media-libs/libvorbis )
+ sox? (
+ media-sound/sox
+ media-sound/mpg123
+ )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-metadata-dir.patch"
+)
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-x11 \
+ $(use_enable alsa) \
+ $(use_enable debug) \
+ $(use_enable jack) \
+ $(use_enable mad) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable vorbis) \
+ $(use_enable sox)
+}